Herelink Air Unit not Broadcasting Signal

Hi everyone! So I’m having an Issue with my Herelink, the air unit is not broadcasting a signal. Per the instructions, I updated the firmware on both the ground station and air unit and can’t connect using Solex.

I keep getting no vehicle detected and can’t update the air unit via the ground station. Any assistance would be great. Below is a couple of snapshots.

Forgot to mention, install Google USB Driver and reflashed the firmware and still get the same error.

I don’t think you have your air unit updated, that’s why it does not pair.

For the LIUSB error, please make sure you have the Google USB driver installed, or reinstall it once more.

If it still don’t work, try the followings:

  1. On the controller, enter fastboot and connect it to your computer
  2. Delete the Herelink driver from device manager
  3. Reinstall the driver
  4. Disconnect the controller
  5. Connect air unit

Thanks Alvin! I must say, after uninstalling and reinstalling the driver about a total of 5 times. At one point the Herelink ground station showed up in the device manager as an Android server, afterwords the firmware loaded flawlessly.