Herelink air unit not recognized

Just recently, this week, purchased a herelink and wanted to try the new solex firmware, while attempting to update the air unit, after successfully updating the remote, I ran into an issue. The air unit is not recognized in device manager and the software downloaded from here simply displays looking for device. Previous to this the unit had been preforming flawlessly.

multiple Win10 and linux machines all show the same issue.
Any help would be very much appreciated.

Cheers,
Nic

Try as follows

Install the android driver

https://developer.android.com/studio/run/win-usb

Then if that does not help

Force Air unit in bootloader mode.

Basically have the flasher program running in detection mode and then power up the air unit while pressing the reset/pair button. If successful the flasher program will detect and update the Air Unit

@MadRC

Thanks for the advice, I tried one win10 64 machine with the google driver and one with the android SDK, neither appeared to work. I am not 100% sure the air unit is in bootloader mode, is there some indication perhaps on the led? Also am I wrong to expect device manager to recognize the device, or for linux to report it with the “lsusb” command?

Is any of the LED on the air unit lighting?
The USB alone is not enough the power up the air unit. You need an external power source connecting to the power port.

@Alvin I had the system powered from a bench top regulated 3A power supply for all testing. The unit was fully function prior to the ground unit update to solex, the led with usb alone does nothing, with power applied it stays off a few seconds then led2 turns yellow. When booting with the reset button pressed per Ian’s suggestion no change occurs however if I continue to hold the button pressed for 5 seconds after power, the yellow light takes a full minute before it turns on. The flasher app on win10 and ubuntu never sees the air unit. While I truly hope I am simply doing something wrong, the fact is that neither linux or windows acknowledge a device on the USB port and that leads me to believe the problem is hardware. The system was tested before attempting the update, it paired, sent SBUS, and returned video but I never bothered to check the USB port. After updating the ground unit I have firmware I can’t regress and an air unit i can’t upgrade to a matching version, however even with the mismatch it does still appear to “pair” but the system is not fully functional. IF allowed, I will happily open the unit up and take a peek, I have an oven and hot air capabilities if the issue is obvious.

Cheers,
Nic

Can you try to use the adb reboot bootloader to reboot the air unit, and see if it became detectable by computer?
https://developer.android.com/studio/releases/platform-tools

@alvin after stumbling through enabling adb, we finally got this result:

Capture

same setup with benchtop powersupply, I tried the command with and without the hidden bootloader mode for the air unit.

Cheers,
Nic

Hi Nic.
Did you ever get to make it work? I´m stuck with the same problem.

Is the Herelink showing up in the device manager?

You may also check if the usb connector is good or not. Bad usb port won’t let you fully plug to the end.
IMG_20200525_161413