Herelink Air Unit - RC Failsafe

Herelink RC enters failsafe, the Air Unit receiver holds the last known pilot command values, until it regains contact with the RC and realizes everything is centered, and switched back to Autopilot.

Failsafe is disabled and will remain disabled.

Herelink
@rmackay9

The failsafe is on autopilot.

Have you updated the Herelink to latest stable?

1 Like

Where do i go about changing this behavior?

Can Ardupilot dictate if the receiver holds values vs. switching back to autopilot?

Thanks

I accidentally didn’t ask the question. I want my quad to continue in a particular flight mode, forget the last known pilot value, and return to automatic autopilot (in that particular flight mode). I think what dictates this is the receiver (air unit) which i do not know how to modify/configure.

They are being set in ardupilot
https://ardupilot.org/copter/docs/radio-failsafe.html
https://ardupilot.org/copter/docs/gcs-failsafe.html

1 Like

I understand that. None of the configurable parameters have the option to allow the copter to forget pilot’s last command, and continue in a chosen flight mode.

In that link you sent me, it demonstrates how to set HOLD or NO PULSES on the receiver. I cannot find anything like that with the Herelink.

The failsafes on Ardupilot simply change flight mode to RTL, Land, etc.

What you want to achieve would require a lua script. There are no failsafe option for changing flight mode in Herelink.

1 Like

Okay, thank you. I’ll have a look into lua scripts.

So there’s no way to physically configure the receiver to not hold pulses?

As far as I know there’s no way to.

I have just tested with my Herelink with latest firmware. It only holds throttle and rollwheel when it disconnects. The other axes back to centre as long as I turned off the controller.

1 Like

Do you mean rollwheel as in the Roll axis? or the input of the wheel in the top left-hand corner?

Thanks

The wheel at the top-left corner

1 Like

That’s cool, what is your FS_OPTIONS & FS_THR_ENABLE set at?

I’m trying to recreate your behavior

thanks!

It is a flesh loaded arducopter. I don’t have any special settings.

You can verify this yourself by connecting everything, go to Mission Planner > Setup > Radio Calibration. Then move your sticks away from centre. Turn off your Herelink controller to simulate connection lost. You will now see what it would do when controller is disconnected.

1 Like

I’ve tried it, just disarms. I’m not using a GPS module fyi.

I’ll update air unit firmware.

I reset params to default
fs_options = 16
fs_thr_enable = 1

image

This is after i turned off my Herelink transmitter :confused:

Are your air unit and controller both in latest firmware?
Can you try again with resetting all parameters to default in autopilot? Try after finishing the RC calibration.

1 Like