Herelink binding with air unit

I am having trouble binding the air unit to the Tx.
When I select pair on the Tx, the message is displayed to hold the link button on the air unit until led 2 blinks. When I do that it takes forever and says it timed out and no parie. What am I doing wrong?

                                              Brent

Are they on the same firmware version? Can you share a video about this?

I need a crash course (figuratively speaking) in the herelink system. I dont know if I have the right updates installed or what. The whole system keeps crashing. I dont know how to share a video

Use the flasher to update both of them. This should make them on same version.

Just record with a phone or something else so that we could know what is happening

Where and how would I send a link to a video on this forum? I see no way to attach a file.

Upload it to anywhere such as google drive/onedrive/sendspace/etc

I’m having binding issues also. I updated the firmware on the receiver and transmitter, still no luck. I have follow the instruction step by step and no luck. What do I try next?

I am new to this community and I want to first off say thanks for all the info and Hello:)

 I am having a similar issue. I have checked the radio is on the right firmware and it is on the Stable Version. The air unit will not pair no matter how I have tried. I do not know if the air unit is on the right firmware and I do not know how to check. Every time I try to flash the air unit it goes through the screen so fast I can not see the details on how the flash went. One more thing I have to note as well is the settings App on the herelink TX keeps crashing when I try to use the D2D  setting or Bluetooth tethering. I hope someone has some insight as to what to do. Thanks in advance

Here is a screen shot of what I am getting when running the flash to the air unit

Please update your USB driver

After ADB drivers were updated it started to work right away. I guess I thought Windows 10 would have all those drivers straight out of the box but I was incorrect. I did notice on my computer that I was only able to see the issue in my device manager when the radio was in fastboot mode and I had the device manager open to see the exclamation point next to it. Anyway thanks to Phil as I looked into it further and he was right it was definitely the ADB drivers.

Thanks again for the response. I’m sure I may have more questions in the future.