Herelink center throttle will not hover

Hi, this is my first build with pixhawk, was always using DJI A3 or NAZA before. Always wanted to try pixhawk as it is open source.

I guess technically it is my second Pixhawk build. I made the very stupid mistake of going straight into setting this up on my 1.5 meter X8. Took the A3 pro off, popped the Kore and cube black in. Got it all setup. First flight did not go so well. After an expensive teaching moment I decided that maybe pixhawk was going to to take a bit more tinkering than an A3 pro and I should put it on something that costs less than one of the props on the X8. Lesson learned.

First off, my thumbs are trained for spring loaded sticks and I have no interest in changing that now. I can’t continue with DJI because:

  1. they suck for integrating anything that isn’t DJI
  2. they discontinued all there autopilots and the M600
  3. I need to be able to lift a payload that’s heavier than a can of beer :slight_smile:

So staying with them is a nonstarter.

SO I have started with an F550, motors, props, and esc’s are bone stock, straight out the box. I am using a spektreworks Kore, cube black, and the original Here GPS as well as Herelink for all things control related and a Tattu 4s 10000 mah 25c battery:)

I have gone through the video for calibrating the herelink. I have calibrated from the home screen drag down menu. I have calibrated from MissionPlanner. I have calibrated from QGCS. I have tried center throttle 0 checked and unchecked.

With it checked it arms at my low speed setting and stays at my minimum spin setting. I can bring it to a stable hover in stabilize, loiter, or alt hold. It will only stay in a hover if I continue to give a bit of throttle. When I release throttle it immediately descends (aka crash if I let it).

With center throttle 0 unchecked I have to hold down to arm and when I release it immediately goes to 50% throttle. This actually seems like what it is supposed to do with center throttle 0 unchecked though. I only tried that setting just to see what would happen.

I need it to come to a stable hover when I release the sticks in althold or loiter (from everything I have read those are the 2 settings it should hover in with no command inputs). I need this thing to be as simplistic to fly as possible as I have a payload to deal with and don’t have time to deal with constantly adjusting throttle in flight to stay at a set altitude. That’s fine when I am flying FPV, not for this. Also, my big X8 is freaking expensive and I was just starting to no longer get heart burn everytime it flew with the A3. I would like to minimize the amount of panic attacks I have when I fly that with pixhawk :slight_smile:

  1. mot_hover_learn is set to 2
  2. pilot_thro_bhv is set to 7

I followed every single step in the herelink setup videos
I followed every single step in the Tuning — Copter documentation

It exhibits really stable flight characteristics for the first flight with no extra tuning. It just won’t hover. Like, I bring it up a couple meters, get my thumb set and it just stays put. Was pretty stoked about that as the X8 did in fact not do that.

I have been through every arducopter and cubepilot conversation I could find about this issue but could not find a fix. I tried just about every idea from those other threads to no avail.

It has to be something glaringly, face palming obvious I just can’t seem to figure it out.

According to the setup and tuning procedure it should be hovering.

Here is the link to all of my logs thus far. The most recent is from 11Apr and is a 5 minute hover. I had to keep the throttle pushed up just a little bit to keep it in a hover. As soon as I let go it descends rapidly. I have test hovered it for about 15 minutes so far.

with just a little bit of pressure on the throttle I can keep it nice and stable in loiter. Alt hold does not actual hold Alt, still needs just a bit of pressure on the throttle. Stabilize works pretty much as advertised.

I can see the two Ctun’s have converged and so it should be hovering nicely.

I am uncertain what to try next so any help would be awesome.


Hello Cory,

I would say that is a tuning problem with the Motors Hover Learn, but as you said, you followed the instructions on the tuning page.

Did you remember to proper calibrate the sticks of your herelink? And the RC Calibration on your flight controller, was also done?

With these two calibrations done and verified, I would increase the RC3_DZ Parameter, in order to give you a larger dead zone around mid-stick to verify if your throttle stick has some problem or is not calibrated.

Did you perform your tuning using herelink or some other RC? Particularly, I do not appreciate a lot the sticks sensibility, so it would be a good practice to tune it using a separate RC to verify if the problem has something to do with herelink or not.

Hi Bruno,

I am using Herelink for all aspects of tuning and I did calibrate the sticks using the drop down menu, QGCS, and mission planner. Probably a half dozen times.

I haven’t tried with another controller as then I have to learn how to integrate another receiver and controller and was hoping to not have to do that. I have a futaba and taranis, but they do not have self centering throttles like herelink has.

I have not done an automated takeoff to see if it would hover. I am curious to see if that would work.

I can adjust the rc3_dz parameter, although I can’t picture how that tells me if there is a problem with the throttle. I am brand new to pixhawk, so the myriad of parameters that can be adjusted and what impact it has on flight and troubleshooting is a bit daunting.

I will give it a go though and see how it works. :slight_smile:

Thanks for the help

Hi Cory,

The thing about the dead zone parameter and other RC device is just to isolate if you have a faulty stick or not.

Seting up a Futaba or taranis with a proper PPM receiver should be pretty straightforward, I can help you if you need.

A nice experiment you can do regarding the herelink sticks, you can open the Radio Calibration Screen on Mission Planner, do several moves with your throttle stick and observe if every time the stick value go back to the value dictated by RC3_TRIM +/- RC3_DZ parameter, because these values dictates for AltHold and Loiter modes where midstick is (as soon as they control climb/descent rates, this is the zero rate input), so that`s why I sugested you to increase dead zone to deal with a possible shity stick. If these values are ok, I would probably discard a herelink issue and investigate some tuning problem with your height controller tuning.

I have also noticed the two parameters you mentioned, MOT_HOV_LEARN should set to 2 only for the first time you fly in AltHold, wait for some seconds until the height controller is tuned for you, you should see the drone going up/down on this proccess, so do it in a safe height from ground. After this, you can set it for 1, I had some problems with this parameter set in 2. Also, I always used herelink with PILOT_THR_BHV zeroed, maybe you should try it only to certify yourself that some option is messing something up.

Thanks for all of your help with this.

I reset all parameters back to default and started from scratch. Went through the Herelink and arducopter setup processes from the beginning with the same results as before.

Just charging the battery now and will try a bit more hovering in loiter and althold with MOT_HOV_LEARN set to 2, then will change to 1 or 0. Will also change PILOT_THR_BHV settings to see if one works.

Will look at the values for rc3_trim as well.

Out of curiosity, if auto takeoff worked to get it in a hover, would that narrow down what I could be doing wrong?

If all else fails I will see about hooking up one of my other controllers. I haven’t used either in years, will have to buy new batteries :rofl: :rofl:

I am using a spektreworks kore carrier board, so not sure if I can use ppm/sbus port on the Kore into the sbus on my old L9R so I don’t have to mess with wiring to separate channels. I haven’t messed with this stuff in ages so very far out of practice (I only barely new what to do back then!).

I uploaded my log file from today as well.

Thanks again for the help

link to the folder with all of my logs. All of todays are from after resetting.

So I tried increasing rc3_dz from 30 to 50 then to 75. no luck.

tried pilot_thr_bhv at 0 and 1 and 7, no change.

after ctun’s converged, tried mot_hover_learn in 0 and 1, no change.

It hovers so nicely with a bit of throttle up, wish I could get it to work properly :frowning: :sob:

I am going to setup my taranis and L9R on it tomorrow (hopefully, I haven’t used it in years and will definitely have to watch some youtube videos). It will likely take at least a day to figure that out.

If it will hover with the taranis then it has to be a herelink issue.

I have another herelink on my fixed wing, not sure if its worth trying that one. If so would it be best to try both air and ground units or just ground unit?


For the tests you did, I definetively think your problem has nothing to do with herelink sticks, it seems ok to me.

In order to connect the Taranis or Futaba into Kore Carrier, simply unplug the RC Connection of herelink from PPM Port and connect the PPM Port from your receiver on the PPM port. SBUS Port of Kore is in fact an output of SBUS and has nothing to do to RC. Do not forget to recalibrate the sticks in your GCS.

I took a look on the logs of today with a friend who is better with control than me and it seems to him that your MOT_THST_HOVER value calculated by hover learn is too low for your frame.

Take a look on this print of one of your flights:

You had to apply around 1575PWM of your throttle in order to guarantee a hover of your drone, so maybe your MOT_THST_HOVER value is low than what is needed. Try to put MOT_HOV_LEARN on 0 and manually increase the MOT_THST_HOVER in 5 or 10 percent intervals and see if you can get a gentle hover with this. If needed, at each iteration try to open your logs and check which value of RCIN.C3 was needed to stabilize CTUN.Alt. At some point you should be able to perform a nice hover with throttle centered (about 1500PWM). If you raise it a lot, you will feel that you would have to push the stick lower than center, so the right value would be slightly lower than this. Maybe using a Futaba or Taranis without the self-centering sticks would help on this test, but as soon as you tune it properly it should work for herelink also. Make sure that you make these tests sufficiently distant from ground in order to have more time to react.

Good luck man!


I tried raising my mot_thst_hover as far as .68 (from .35) and it still would not hover. It didn’t even look like it was getting closer to a hover.

I did get out to a place where I could do an auto take off and it worked flawlessly. straight to a rock solid 3 meter hover. Swapped to loiter and it dropped immediately.

Dropped 2 more logs in the folder.

Log playing with mot_thst_hover setting

for auto takeoff

I got a new battery for my Taranis and will start going through videos on binding and setup. It will likely take me a day or 2 to get it to a point I am comfortable hovering as I haven’t used it in years.

Hey man,

Sorry that it didn`t help you… I saw your logs and I did not see nothing that was really strange.

Regarding the Auto mode, in general even bad tuned drones can fly good, and there are many different parameters between loiter and auto mode.

I will await for your flights with Taranis to see if I can help you better.

Hi Bruno,

I am guessing that auto takeoff by passes the Herelink controller and flies straight off the autopilot.
I was wondering if this meant the autopilot was working as advertised so the problem would likely be with the Herelink? So, if I removed the Herelink and flew only using a joystick, my computer, missionplanner, and telemetry, and it hovered properly, would that completely remove faulty parameters in pixhawk as the culprit?

Before drones I was an aircraft engineer and there was always tests we could do to home in on the faulty component. Each test we conducted would remove other components from the list of potential problems, until we were finally left with only one.

So I relearned how to use my Taranis X9D and got it all setup with the F550 ( I think at least).

In loiter and Althold it hovers at about 1 click above center throttle. Is that pretty normal? I never really got a chance to use the Taranis or any other non-spring centering controller so I have no experience to pull from.

Here is the link to my last flight.

It seems to maintain altitude pretty well. There was a little bit of wind, it seemed to hold a hover much better in loiter than alt hold.

MOT_THST_HOVER is at 0.49 with the Taranis. With Herelink it was always around 0.33.

RC3_trim is still right at the lower limit, although I don’t know if that is something I am supposed to change or if it is supposed to happen during a calibration. I did calibrate the taranis in missionplanner.

I will try autotune tomorrow if I get a chance. There is a bit of a weird yawing action it does every 30 seconds or so. The motors change pitch and it yaws about 30 or so degrees (I think nose right, but am just realizing I didn’t pay enough attention to whether it is the same direction each time). It always self corrects, but wondering if I can tune it out. Not entirely sure if there is something in the logs I can check to base a tune change on.

I am hoping that getting it tuned on the Taranis translates to tuned on Herelink.

Thanks for any help


I wouldn’t say it with 100% confidence, because there are different parameters that control Auto/Guided flights and different ones for Loiter/AltHold modes, so it wouldn’t be sufficient to confirm it.

So, it seems you have the same problem as before right? The only difference is that you do not have the annoying springs in the stick so it maybe feel more confortable to fly. Maybe you could try to increase THR_DZ parameter… I think this one properly controls dead-zone from throttle mid-stick.

Yeah, maybe you need higher gains for Yaw, autotune may help in some way.

Ok, so after a few more flights (link to last log) it seems to hold hover with throttle at center in Althold and Loiter. The dead zone seems to be from center throttle to one line mark above and below on the Taranis X9D. Slowly moving the throttle within those marks does not seem to affect hover, only when I go above or below.

So either there is some parameter in MissionPlanner that is critical to Herelink specifically, or a calibration issue with Herelink.

I had tried calibrating and recalibrating around 6 times with no luck before I swapped to the Taranis and L9R.

I am going to play with THR_DZ to see how it works with the Taranis.

I haven’t had a chance to autotune as I need to go to a bigger area. But it seems to be pretty stable in Althold. I don’t really need or want it to be ultra responsive or aggresive so autotune may not be necessary.

I will continue to tune to try and get it dialed in tight, but not sure how much better I can get it as a noob.

One strange thing (off the hover topic) is the Yaw. I didn’t time it, but throughout the flight the motors would massively change pitch (as in sound) and it would yaw 10 degrees or so (I think it was nose right each time) and become a bit unstable. Nothing crazy, just a bit unstable. Then the motors would change back to a nice lower, smoother pitch and it would go back to quite stable. This happens at intervals throughout the flight.

My hope now is that if it is tuned and hovering with the Taranis, it should be fine with Herelink.

1 Like

Continuing with tuning. I will get back to the thread after full tune complete and then reinstall the Herelink. Hopefully it will hover!

1 Like