Herelink CH 3 Reversed

Channel 3 (throttle) is reversed on my herelink in mode 2, it won’t allow me to calibrate says set transmitter CH3 to normal then calibrate. how do I do this on the herelink transmitter

Where is this message?

The warning came up after trying to calibrate in radio tab of QC. Since my last reply I have done the joystick calibration in the hardware test menu ##6448## now I can calibrate joysticks in QC both radio and joystick.




Having the same problem, can’t access test menu from the dialer with either of those codes. Can someone help?

Thank you @Julien that code did work.

I was able to do the joystick calibration in the hardware test menu.

The problem, however, persists… my throttle in QGroundControl is still reversed.

after doing the calibration hardware, go in QGC > settings > RC and do a calibration here (assuming you use the 0_2_2 version firmware)
It should solve it.
Anyway you can connect Mission Planner to your Cube and reverse the channel (CH3_REVERSED)

That is right, but don’t consider to do that, there is obviously something wrong. Solve the issue not the symptom.

Funny thing, I have the same problem with a unit after I flashed the may firmware. Is there a´real solution?

Edit: could it be that channel needs to be inverted in the Herelink app in this firmware version? I have realized that my other copter has the same issue, I crashed it because of that (I habe checked that again, its not true, channel seems to be reversed by default). It did hold altidude, I guess that is the reason???

@philip, @sidbh is there a hint missing in the update post?

The latest firmware allows all RC channels to be reversed.

Please see the info in the Wiki under this now.

Yes, it gets more complex. Somehow the Herelink app calibration screen does not display the reveresd action clear enough. Would be great if one could see it directly, so see the values which are outputed on sbus.

Herelink is showing you the inputs from the sticks. To see the outputs you would look at the RC screen on your software or in QGC.

Hi @hextd did you manage to finally fix this issue? Is the issue solved, not the symptom ?

I can’t even reverse channels via mission planner, the button seems to be missing.

Did the sensor calibration on the herelink and everything, still can’t calibrate the radio…

Channels are now reversed here

This is all resolved in the latest firmware.

Don’t forget to “SAVE”

Yes, that resolved my issue. I needed several tries, maybe because I forgot to hit save, but finnaly it worked. I did all calibration steps within Herelink. I do use Mission Planner for everything else but not for the RC calibration.

How do I access this menu? I do not see it in Solex. I have the same issue with a reversed throttle on my Herelink.

EDIT: Nevermind, I found it in the Herelink Settings App