Herelink controller (Control Station) not powering on

My Herelink controller (ground control station) will not power on. It worked great for a flight two days ago and was charged up that evening. One day ago I powered it on and downloaded a tlog. It was then put on charge for less than one hour to top off for several flights today. Now I cannot get it to power on, and there are no LEDs lighting up. It does not appear to be charging either. Any ideas? Could the battery be bad, if so how do I replace it? Thanks for any help!

Please try to charge it for a few hours then connect it to computer while USB still powering it. Then see if computer detect it.

Thank you for the reply, Alvin! Today I tried charging the controller (3 hrs. with a charger that is know to work) and then plugging it into two computers (through the usb cord) looking for the connection through device manager. Additionally, I looked on the Wi-Fi menu to see if it was detecting the device. The controller was not detected through any of these methods.

The manufacturer of my UAS suggested that I connect my aircraft to mission controller and check the RC calibration screen to see if by chance the Herelink controller is broadcasting without a screen. Again, I see nothing indicating that the RC signal is being broadcast.

There are just no signs that the controller is powering up!

Try to put the Herelink Remote Unit into Fastboot by pressing Power and D button simultaneously while turning on and see what it does.

Thanks Ian, I gave Fastboot a try and had no luck. I’m think this thing is bricked!

Probably battery problem, you may contact your reseller for RMA.

i got the same problem after update it is not turning on and also its the latest one i charged it with my mobile charger

I have the same problem on a brand new unit I was running the first update on.
Connected fine to my wifi - ran the registration and update left to run (unit fully charged) - now the unit shows nothing on the display.
No LED on the top left.
Power on Button causes my laptop to ping and then ping again after about 5 secs,
If I remove and disconnect the USB lead I get a ping and W10 says and Android ADB interface has connected.
image

This is not the same as a working unit, they do not cause a ping if off and if on they show as an Optimus device on device manager. They also show the Green charging LED and hex logo when USB connected followed by a battery status icon - none of this on this new unit after running the update.
Power on / D does nothing.

I’d disconnect the battery for 5 minutes if this was a phone and I could get to the battery.

Any ideas?? (I’m going to leave it off charge for a few hours to see if I can get the Hex logo when USB power is restored).

Same here. Since the update, it seems that the ground station I just bought is dead. The LED indicator also don’t light up, if I try to charge it.

Looks like we are going to have to RMA these dead ground units, just hope the replacements update without this issue.