Herelink crash after upgrade Solex 1.3.0

Good morning guys…. I have a terrible problem. Herelink with 2 cams (stream 1 + Stream 2)… with previous Solex version (I don’t remember exactly but probably 1.2.7) everything was ok. Today I updated the App to 1.3.0 and when I switch between the two channels the remote control crashes. Crash I mean that everything crashes and I have to press the On/Off + D key simultaneously for 10 seconds. With the GCS App on the same RC everything works regularly so I think it’s a Solex problem. I have two questions: when I update the App, don’t I have to update the AirUnit as well? How can I downgrade the App back to the previous version?

Help me Kelly!!:smiley::smiley::smiley:

Thanks everyone for the advice

( I did the debug download, if you’re interested)


Which Ardupilot firmware version are you using .

Hi Sibujacob,

now 4.3.5,but the problem is only with Solex 1.3.0
The previous version didn’t crash all the RC. Also if I use QGC it doesn’t crash so I think it’s just the newly updated version of Solex

1 Like

Hi Frank,

I can tell you that the only change between Solex 1.2.9 and 1.3.0 was a change to a variable reference related to the Payload Drop functionality (it was using the wrong servo channel), and there were no other changes at all. So it’s very unlikely that you’d see any difference between 1.3.0 and an earlier version.

What you describe here sounds like the HereLink itself crashing, something at the OS level, is that right? If you’re forced to reset the device itself, then that’s outside what an app is able to do. Is this a Herelink 1.0 or a 1.1 unit?

And just for future reference, in general you don’t need to update the air unit when you update an app.


Hi Gents,

i too had a similar experience where the Herelink Airlink unit did not have the LED 1 light up. I assumed it to be the S-bus issue and had to flash the Airlink firmware through USB even though i was on BETA updated version ! Know idea why it happened. Anyways , it is again back on latest firmware without being on the BETA channel

Hi Kelly

Nice to hear from you and thank you for the explanation.

However, I would like to clarify a couple of things; first of all I don’t remember exactly the previous version but it could also be 1.2.7 (not 9), also I noticed that if I load QGC it doesn’t crash. I haven’t tried it for hours and hours in QGC but, on the contrary, if I turn on Herelink and launch Solex, after 2 or 3 times I switch between cam 1 and cam 2, everything herelink crashes (shutdown 10 sec On key /Off + D)

This is Herelink 1.1 with AirUnit with Ethernet connector.
The Herelink firmware is from 2023 (if needed, I’ll quote the release in the next post)

Detail 1: if I turn on herelink and I don’t “play” with the two streaming channels, on AirUnit Led 1 flashes yellow/red and Led2 is fixed on yellow. When I start playing with the channels and it crashes, the Led1 of the AirUnit is fix on Yellow

Detail 2: With QGC I can play smoothly switching from Stream1 to Stream2 and it doesn’t crash

In the end, I can consider doing a Herelink factory reset and see if it has the same problem with the native release.

Thank you again

this is the log (1.2 MB)

EDIT: I just discovered by reading the log that the Herelink remote purchased 3 months ago is identified in log with 1.0 and the AirUnit is the one with the ethernet connector. Can RC 1.0 talk to AurUnit with Ethernet?
Maybe I’m wrong but the Herelink 1.1 version is accompanied by AirUnit with Ethernet or am I wrong?

VERY SORRY (but I’m ready to retract :smiley: )

I thought I had the latest version available on Herelink but evidently I confused this RC with another Herelink system updated to the latest release (still mine… I’m a good Herelink customer :slight_smile: ).

In the Herelink discussed here, I checked and noticed that I had an old version (AU01220917) while the latest available is AU01230714 which I immediately loaded and everything seems to be more stable

The question of the questions is therefore the following: Is it possible that the App version V. 1.3.0 had problems with the previous version installed on Herelink (AU01220917) ???
I mean… does the app version have to follow the Herelink version in any way? and what margins of differences between the versions should not be exceeded?

Thank you


Sorry for this constant changing version and impressions but I’m doing the real time history of what is happening with the hope that it will be useful to someone else

After downloading the latest version Herelink AU01230714 and installing the latest available update of Solex V. 1.3.0., it happened 2 more times within half an hour that the remote control blocked completely (i.e. exactly like at the beginning of tale). Unlocking always takes place in On/Off + D

Luckily all this happens on the ground and not in flight.
Typically the HDMI protocol (Cam1) starts to get corrupted and then everything stops

I tried in the same conditions to work in QGC staying connected for a long time but it never happened that it lost the signal, nor that it corrected HDMI nor that it crashed Herelink

At this point I suspect even more strongly that the problem is located in Solex (since it always crashes using this App.)
I’m an admirer and fan of Solex and I wouldn’t change it for the world but please Kelly give me the solution to solve the problem
I can do a reset of the settings and so maybe the app goes back to 1.0.7 (I’ve never had any problems with this version)

What can I do? … Thank you


Hi Frank

I worked a bit on your problem and I’ll answer it here (although I could answer you in person because we know each other :slight_smile: ), but maybe this helps others

The problem is all in the type of power supply
When the voltage is in the range then everything is ok… during the various tests, however, perhaps you forgot about the battery (also because the threshold alarms are all disabled) and when the systems are underpowered, the remote control crashes (loop continuous
In your case this happens when all the UAS has a voltage below 7V (the current also increases obviously)
I checked with a laboratory power supply with adjustable voltage and actually below 7V the remote control crashes with the Solex app while QGC continues to work in the native functions and DOES NOT block the remote control


Little message for Kelly… I hope my reconstruction can somehow give you some valuable information. It is certain that it is not possible to use a UAS in underpowered condition but this is not the crux of the dispute; what I want to specify is that the AirUnit has the property of crashing the whole remote control. Probably as the voltage decreases (initially at 22V and 0.9A) and the physiological increase in current (7V and 2.8A), the AirUnit starts to heat up (despite the cooling fan) and when it heats up it goes into protection. Consequently the remote control waits for some input from the AirUnit which does not arrive and goes into a loop involving any basic function of the remote control (no hardware buttons and touch controls)

I hope I have explained everything and brought to light a bug that even if fixed would be useless but having Herelink totally in a loop is never pleasant. An Escape function would be helpful

I’ll admit to being a bit confused after reading all this. :slight_smile: There are a lot of version numbers flying around here, so let me just clarify that there is no requirement to stick with one HereLink version or another just to run the app. It’s expected to run on either one. So to state the problem: You have two cameras connected to the Herelink and are able to smoothly use them both with QGC but reliably get a crash in Solex 1.3.0 that is severe enough you’re forced to reboot when you switch video streams? And this did not happen in versions of Solex prior to 1.3.0? What happens when you do not switch video streams? (That’s mainly for debugging, to see if there’s possibly an issue with switching streams.) I’ll try to reproduce it, but I need to know the exact thing you’re seeing so I don’t end up in a blind alley chasing this. Thanks!