Herelink Firmware Update: Product Key Not Working

“Cannot register your device” shows up every time I try to input the product key on my herelink groundstation.

I have an older unit which required me to ask getfpv for the product key rather than one being provided with the unit.

Support at getfpv provided me 3 different product keys. They told me to update my time zone to the correct one and try using the wifi hotspot on my phone. None of these suggestions worked.

This is getting frustrating, not having access to my device.

It’s usually a connection issue that, Mobile hotspot usually works with the correct time zone.

You need to avoid networks with 192.168.x.x ip ranges.

I’m not very well versed on WLAN. Can I just set the network to a static ip address? (on the herelink wifi settings for the network)

I have tried my normal wifi, windows 10 mobile hotspot, phone mobile hotspot and some static ip settings for both of the hotspots.
I did “modify network” on the wifi hotspot and set a static IP of
The rest of it autofilled as I went through.
I also tried and with no luck.

It’s possible the keys they have given as wrong. @Michael_Oborne can you help on this one.

Still not having any luck. Any suggestions on how to get this up and running. I am trying to test my drone but haven’t been able to with this out of commission.
I appreciate all the help thus far.

changing the ip like that is not how this works

when set to auto/dhcp, what ip does the herelink get?

Josh, I had the same issues. Like Mad said, triple check your product key is accurate.

There is only one way for the registration to work because of this terribly buggy software. Your Herelink controller must receive a dynamic IP address (dhcp), within the network address space.

No other subnet will work, Static IP will not work, hotspot IP will not work, public hotspots will not work. I ended up having to drive to a friends house and use her network because I did not want to re-IP my whole home network all because these lazy devs won’t fix the problem.

I’ll try roaming to other wifi access. Thanks for the help!

I agree this is very frustrating. While I understand why the protection is in place, it shouldn’t brick my device indefinitely. I was aware of the product key requirement before flashing to a new firmware and made sure I had the product key prior to running the firmware flash. I didn’t plan on not having access to my ground station for 2+ weeks.

They should be making life difficult for thieves, not customers.

if you private send me the key, i can verify the key correctness. and if it has been updated before the android device SN as well, so i can trace it.

1 Like

The 3 keys given to me were incorrect. Michael was able to verify that they were incorrect and provide me with the correct one.


Hi, Michael having the same problem with the keys, so I have two herelink with me I’ll refer to them as 1 and 2. so the original product key that I have for 1 was not working so I contacted the reseller and he gave me another key which is also not working. In 2 the product key that I have was the same as the reseller had but that key also didn’t work. Also, I have checked this number of times my time zone is correct and IP also seems to be correct tested on multiple routers and hotspots. something which is different in 1 and 2 error is in 1 it says cannot register your device and then date and current time and on 2 it only says cannot register

this one is 2
this one is 1

please try again, there was a server issue yesterday

I am don’t think this is a server issue I have been trying key for past 1 week and I also tried today still not working

could you just help me verify the keys or maybe provide another solution cuz I have been trying out a different solution that I found on the forum nothing works. wifi is definitely on the 5.8ghz band, region is supposed to be china (for Indian users) , can’t do anything about IP since its automatic dhcp but subnet is not 0 and also tried going through settings and then system update and check update here i think it shouldn’t ask for product key but it still ask for it . there are the few fixes that i have tried and what the reseller also told me to try

please PM the details
idealy need the key
and the device SN
you can get the SN from Settings > About Phone > Status > SerialNumber