Herelink ground unit resets in flight

I’m having an issue with the Herelink ground unit resetting in flight when I’m connected to an RTK base station and am transmitting a video feed to the Herelink and the base station.

I originally had a Cube Black running Arducopter 4.0.7 on the drone and a Here3 GPS which, through some custom work, was able to run RTK. That was proven to be reliable. However, it was then shown that at approximately 2 minutes of flight time while being connected to an RTK base station running QGC 4.0.5, we would get “Communication lost” and the GCS would do a power reboot. Luckily we have a reliable RTL set up so we never lost the drone.

This problem also seems to exist exclusively while the video feed is being streamed to the RTK base station. I haven’t had any issues when flying with video feed only going to the Herelink even if I’m using an RTK GPS connection. Interestingly, I have tried a different RTK base station with a “Development Head” version of QGC (I’m not entirely sure where that came from) and I didn’t get any resets, but, as a company that sells these systems as a standard product, we don’t want to rely on an obscure version of QGC.


I’ve tried changing out the GCS, updating the firmware on the GCS, using a different Flir Duo Pro R, upgrading the GPS to a Here3, and upgrading to a Cube Orange running Arducopter 4.0.7, but the results are the same.

I’ve been able to rule out thermal issues as this has been a consistent problem during the afternoon heat as well as the cool mornings and evenings (around 70 F).

This leads me to believe it has some correlation with the software/firmware of the Herelink itself. Maybe it can’t handle/process the information of the video stream. Maybe there’s some quirk in the development that’s above my pay grade that someone could shed some light on.

I’ve included all the crash reports that I was able to save below. Hopefully that provide some useful information. If anyone has had similar experiences or knows what might be causing this issue, any insight would be greatly appreciated. (875.8 KB) (1.0 MB) (1.1 MB) (881.2 KB)

1 Like

Did you read this thread? HereLink controller unit powering off during flight - #28 by khizaryasir

The problem may be the same. If you stream video from Herelink to another device, you get that issue. Try to use an external modem/router as hotspot (to avoid the hotspot from the Herelink itself) and this could solve the problem.

1 Like

I took a look at the bugreports and there is something really weird before the reset.

It complains about no space in some logs I was not able to find any info online ( my guess is they belong to some propietary part of Herelink firmware ):

[ 1444.772544] BRIDGE: lmi40 pkt No space! buf_get=0xffffff801597c1a8,buf_put=0xffffff801597c1a0, modem status:e2f1
[ 1444.772566] BRIDGE: lmi40 buf put ret:fffffff4 rcvoffset:2f sndoffset:2e

It is interesting also that just before that this message is thrown:

[ 1444.510446] bcmsdh_sdmmc: Failed to Read byte F1:@0x10019=ff, Err: -16

Which should be some hotspot issue right?

@Michael_Oborne if you have the time could you please take a look at the bugreport? thanks!