Herelink ground unit stop sending heartbeats when QGC out of focus


we realized under some particular situations QGC in Herelink stops sending heartbeats, and thus the autopilot triggers GCS failsafe. It happens usually when you put the app out of focus ( going to settings, etc ). I think this should not happen, it is like in a desktop machine a GCS loses connection when minimizing the window.

We have tested regular QGC in regular android and the problem doesn’t happen, they work just fine. Is this a known bug? If so, is there any plans to solve it?


Yes confirmed, there is no Background activity manager on the unit.
@Michael_Oborne is there a method to keep GQC active in background ?

1 Like

goto settings, search for battery optimization > turn on all apps, and disable it for QGC

1 Like

I just tried this, and although it seems like it improves and some combination of exiting the app and re-entering don’t trigger the GCS failsafe anymore, there are still some that do. Thank you for the tip though.

Hello @Michael_Oborne ,

Diego works with me, we tested your suggestion but unfortunately doesn’t solve the issue 100% of the cases. There is anything else we could do about it? This behaviour can be very dangerous under some situtations…


i think i need more info on your use case. what is it your changing away from qgc to do? are you loading some other cpu/memory intensive app?

Hi @Michael_Oborne,

Your solution does seem to have helped but if a user goes into the android settings or into the button settings for the herelink, the GCS failsafe will trip. These actions seem relatively likely that a user would perform sometime in the life of their drone during a flight.

Is this under situation that optimization on QGC has been turned off?