Herelink HDMI 2 Feed Issues

I’m having problems receiving video feed through HDMI 2 when no camera is connected to HDMI 1. I like to leave HDMI 1 open for a primary, mission-specific camera while having a GoPro Hero 9 permanently connected to HDMI 2 for FPV purposes. I’ve found that if I connect the GoPro initially to HDMI 1, I’ll get feed and if I then switch it to HDMI 2 (without unpowering anything) it’ll show up in HDMI 2. However, without a camera initially plugged into HDMI 1, no GoPro video feed will show up for HDMI 2 on a full power up.

Has anyone else experienced something similar and/or is there a way around this issue?

Yes, HDMI2 alone does not work for me as well. Only from time to time it may start the stream on powering up.

Worth noting that this issue only exists since one of the updates mid last year. I had to rearrange my build in order to be able to use HDMI1 as primary input.

Prior to that HDMI2 was fine.

Same thing here. On initial startup my HDMI 2 wont come up. I have my camera plugged into HDMI 2 because of the space that my setup allows. However I think that it more often works when my herelink ground system is turned on and opened to QGC first, then plugging in the drone. I think it may also help if the camera is on before the drone is plugged in, however I agree fully that it should not be a problem in the first place.

I tried with my Herelink with computer HDMI and doesn’t seem to have this problem.

Does it happens if the camera is plugged after both camera and Herelink are turned on?
From your descriptions it seems this problem appears when they are initially connected before turning on the system.

In my case it happens when the cam is plugged in before powering the system.

Ill have to test this out then, maybe the best approach is to turn all systems on, then plug the hdmi into the camera, already turned on beforehand?

I have tried my setup again
It seems that QGC has no problem getting sole HDMI2 video at both connected before/after air unit powered.
But in Solex, sometimes it doesn’t get HDMI2 signal after rebooting airunit alone. If I reboot both controller and airunit when HDMI2 is connecting, Solex can’t recognize HDMI2 stream.


, I suspect something we have done in the background changed the performance on using HDMI2 alone. But please notice that Hdmi1 is primary. If only using one video, HDMI1 is the one to use.
However, we do hope to fix this in future as this is part of getting dual video working, but we don’t have the exact schedule for that.
Solution for now is to use HDMI1.

Thanks for your feedback @Alvin. Much appreciated.