Herelink - Hero 7 & Other Camera Don't Work


I’m having issues with getting the Herelink to detect any video feeds. I originally bought a Split ‘Herelink Compatible’ camera and haven’t been able to get it to detect on the air unit, even after firmware updates on the camera, changing the output to 1080P/30, ensuring NTSP out and delayed power up.

I also tried just connecting to a standard GoPro Hero 7 and I am experiencing the same thing, no video detected on the Air Unit. The Air unit is on the latest firmware and is a 1.0 unit.

Any suggestions or support are appreciated.

Thanks, Callum

some things to test

  1. plug into hdmi1, not 2
  2. ensure everything is paired, powered, then open the GCS apps.
  3. ensure the gcs apps are closed, press SQUARE, and swipe away all apps
  4. after power up attempt etc, plug usb into air unit, make sure you have adb installed, and run “adb bugreport” and upload the log file here

Thanks for the response Michael.

Made sure it was in HDMI1. See below the attached log file: (261.1 KB)

ok, so one step i missed, with the bugreport, needs a little bit more time before doing the dump… ie power up as normal, try use the apps. wait 30-60 seconds.
then adb bugreport

Ahh, no worries. Here is the latest bug report: (353.3 KB)

Just pinging this thread again.

ok, so the log shows its not seeing the tmds clock

so are you using the stock provided cable?
how are you powering the herelink?

the reason for these 2 questions is around cable quality/noise rejection
and also noisy switch mode power supplies

ie from

shows the clock originates from the camera, and is sensitive to noise

I’m not using the stock-provided HDMI cable but I am using a Raspberry Pi Micro-HDMI cable with an adapter back to Micro-HDMI. I have confirmed this setup works when plugging into a small Micro-HDMI monitor.

I’m powering the Herelink Air Unit and camera off a variable bench power supply sitting at 10V.

Thanks for the insightful response!

can you try a battery? 2s or 3s lipo?

Unfortunately no difference between a battery vs a power supply.

Also now tried on a Hero 3+ and still have the same issue.

have you updated the fw on the here3?

also as another data point
let the herelink boot,
then plug the camera in. also on the camera is it going into hdmi mode?
and check the camera hdmi output is set to 1080p