Herelink joystick calibration FAIL

I just updated the Herelink controller and air unit to the latest firmware version. After successfully pairing the air unit, got some problem with the calibrations.

I’ve PASS the “HW WHEEL CAL”, but FAIL to finish “HW JS CAL”. By following the upper-right instruction steps during the joystick calibration, the R-X/R-Y/L-X/L-Y always showing 0.000, and can not complete the last step with “PASS”, the black circle just won’t move.

Also tried to reflash the firmware twice, and updated to Beta OS, the calibration problem still the same.
Any idea what might be wrong?


Can you post a video to show. The screen is a little confusing at first as you need to follow the little joystick label at the top.

Hi Ian,
Thank you for quick replay, here is the calibration steps I have done.
Please feel free to offer your suggestions.

Ok your doing everything ok however try this.

Before you start it click save at the top to create a new profile. Then save a button config like A short press to something just to put something into the profile and then try the calibration again.

Do the HW wheel, click save then try the joystick one.

The movement won’t show on the boxes till the end but it should kick in once you ready to move the circles.

Hi Ian,
I’ve tried the way you suggested, the problem were still the same. HW JS CAL just wont pass and nothing happened during the calibration.

But, I’ve found that when changing to the BUTTOM page, “setting fail” message will pop out.
Any ideals? or the problem was caused by hardware malfunction?


@Michael_Oborne any ideas. Sounds like a config file issue to me.

what you have done looks 100% correct. only thing i will add is maybe try reboot it after the calibration, this shouldn’t make any difference, but git it a shot.

if that doesn’t resolve it might need to RMA it

1 Like

Hi Lester, I have the same issue. Were you able to resolve yours?


Have the same problem, after updating the FW to Beta. The joysticks were working before the update


I have the exact same issue. I did send it back to the reseller several weeks ago, I hope it will be fixed in the next months?!

Lester, I solved my problem.
What you show in the video at around 2m is good. Just continue with what the left box is telling you to do. The right screen is not updated (yet). If you continue doing, at some point it start updating and working. Quite confusing but its working