Herelink Keeps Randomly Disconnecting

Hi all,

I’m facing an issue with my new herelink v1.1, that it keeps on randomly disconnecting.

Sometimes it disconnects within 15 seconds, and sometimes after 2-3 minutes, sometimes after 4-5 minutes.

Today while flying, it disconnected randomly and then kept on re-connecting and disconnecting every 5-10 seconds or so.

I tried to get a look at the air unit LEDs, and both were yellow, which confirms that the air unit had power.

Both the antennas are placed on the legs of the drone at around a 15-20 degree angle and the air unit also has fan installed, and mounted on carbon fibre frame for better heat dissipation. Both the air unit and GCS are running latest available firmware.

This disconnection isn’t related to telemetry or sbus cable being loose or something because, in the frequency spectrum page itself, the signal disappears as shown in the pictures attached.

@philip asked me for the debug logs, which I was able to generate using adb.

Capturing the disconnection in the logs was difficult, since the disconnection is very random, and the report duration is also very less, but somehow after many retries, I was able to capture it in the report.

I am attaching the images and the logs with this thread.
Please kindly help with this.

@philip @Alvin @Michael_Oborne (871.2 KB) (1.1 MB)

What fw versions in gnd unit and air unit

Hi @Michael_Oborne ,

GU version: RU01230629
AU version: AU01230714

ok, fw versions look ok.

first thing i would do is factory reset the gnd unit. to ensure its not a leftover setting

Hi @Michael_Oborne

I did the following experiments:

  1. Firstly, as per your suggestion, I tried factory resetting the unit and then setting it up again with stick calibration and everything, but the issue is still there!
    I don’t see any improvement. It still disconnects randomly.

  2. Secondly, I even opened up my drone and removed and reattached the antennas to the air unit just to be sure. When I repowered the drone, I could still observe the issue after 2-3 minutes.

  3. Thirdly, I suspected whether the Air Unit’s BEC could be the issue or not, so I connected the air unit to my bench power supply and injected 9 volts. It drew around 0.23 Amps but the issue is still there! It disconnects randomly even with a bench power supply, so BEC is not the culprit.
    However, I noticed that when it disconnects, the current draw increases from 0.23A to 0.33A, and when it reconnects, the current draw becomes 0.23A again. I don’t know whether this information could be useful for you or not, but the issue is not getting resolved!

What’s going on?! What’s causing this random disconnection?
Is it a faulty unit or what? Please kindly help with this as my complete work is stuck because of this!

@Michael_Oborne @philip

can you get a adb log from the air unit as well?

i can see the disconnects. but still trying to find a possible cause.

Hi @Michael_Oborne,

I tried taking the log from the air unit, I don’t know why, but when connected to ADB, the disconnection becomes very rare.
So I tried for more than 1 hour and after around 15-20 adb logs, finally, I was able to capture the disconnection in a log.

Attaching the log from the air unit for your reference.
Please kindly review it, and suggest some solution since my project is stuck because of this.

Divyanshu (651.8 KB)

Hi @Michael_Oborne @philip
Please kindly help with this.

How shall I proceed with this? If it’s faulty, then please kindly allow RMA here, as my complete work is stuck because of this.


@Michael_Oborne is still investigating this, you are welcome to discuss RMA with your reseller, however, if it turns out to be an operational issue, then new hardware will not help you at all.

Obviously if we discover this is a hardware problem, we will replace it.

An RMA is a slow process as we need to get it back and determine the problem before replacing the unit. But if we determine it’s a hardware problem in this testing, then we can assist your reseller in speeding this up.

You must go through your reseller for RMA.

Hi @philip,

Thank you for your response.
Is there any faster method?

The reason I’m asking this is I’m quite experienced in using Herelink, and this is my 4th or 5th herelink till now, and I don’t think it’s some operational issue.

It wouldn’t be possible for me to wait for soo long for the unit to first reach my reseller, and then reach you, and then wait for your tests, and then finally after soo many days get a replacement.

I hope you understand that my customer wouldn’t wait for that long. No customer will wait for that long.

The only reason I am still a fan of Cubepilot products is their quality and support, but getting this much trouble wouldn’t be possible for me.

Since I have provided you enough logs and data for investigation, it’s my humble request to you to please kindly provide a replacement to me, as my complete delivery schedule is messed up because of this, and I can’t delay it more.

I am ready to send the unit to my reseller for RMA, but please kindly provide the replacement as soon as the unit reaches the reseller. After that you can continue with your investigation.

I hope you understand. Please respond.


can you please confirm you did do a factory reset on the air unit?

i can see something in the log that indicates the air unit is resetting the link.

but need to confirm you have fully factory reset it.

ie using “flasher_win” or similar

Hi @Michael_Oborne
Thank you for your response.

Just to be sure, I did all the steps again, as follows:

  1. Firstly, I used “flasher_win” to flash the Ground unit, and it got flashed with firmware FRU01221123.

  2. Next, the ground unit booted, and on the starting screen it went to the update screen and there was no other method to proceed without updating it. So I updated the ground unit from the update screen, and it got updated to firmware RU01230629.

  3. Next I did the stick calibration on the ground unit.

  4. Now, I used “flasher_win” to flash the air unit, and it got flashed with firmware AU01230714.

  5. I paired the GU and AU together and started QGC. It started normally with the video stream working and all normal.

  6. I waited for a few minutes, and it disconnected :frowning:.
    The frequency spectrum page went blank as shown in the pictures I uploaded in the starting. And now, the same thing started again, that it reconnectes in 4-5 seconds, works fine for 1-2 minutes, disconnectes again, reconnectes, and so on.

At this point, I am pretty sure that it’s not related to any setup issue or anything.
What I know is this issue has wasted more than 10 days of my time and my customer is literally dancing on my head.

Hi @philip,
Since @Michael_Oborne has mentioned in his previous comment that “i can see something in the log that indicates the air unit is resetting the link”, hence it is self-explanatory that it has something to do with the air unit itself, and not related to any setup issue.

I am ready to send the unit back to my reseller, but I can’t wait for all the bullshit process for it to first reach you and then wait for your results. That process will easily take more than a month minimum.

I have provided all the information I could, and since the issue is now pretty clear, it’s my humble request to you to please approve the RMA immediately, so that as soon as the unit reaches my reseller, the reseller can ship a new unit to me.

I hope you respond soon, and provide an acceptable solution to this.

For RMA you MUST go via your reseller. Post them this conversation, and they can discuss the next steps with us.

Hello everyone,

I got the replacement of the air unit from my reseller, and the Cubepilot team helped in making it quick.
The new air unit is working fine without any disconnections, with the same connections as the previous air unit.
Hence I can conclude that the previous air unit had some fault which was causing it to “reset the link” as @Michael_Oborne confirmed from the logs.

Thanks everyone for your support, especially @philip and @Michael_Oborne