Herelink map loading problem

I have my Herelink connected to the 5G-WiFi, but it can’t load any maps.
It can locate itself and the drone position.
But I got white background all the time.
I try changing the provider of the maps and it won’t help.

1 Like


Does anyone have a solution?

Chasing it up…

I encountered a similar problem and was looking for a solution. I connected to the 5g network but could not download any maps

How are you connected to the 5g network?

I searched for a 5g wifi network and connected to it as usual, my phone works but herelink does not

After trying to download the online map unsuccessfully, I downloaded the offline map on pc and copied it to the SD card and it worked


How did you do^^. Show us please!

You have to install qgc for PC. Then go to offline maps and download the area you want. When everything downloaded at your pc then you copy paste to herelink qgc/misssion/ folder and then from qgc of herelink go again to offline maps and import them. Hope I help you.
Ps. When you plug USB cable in herelink you have to change usb function from charging to transfer files.


See comment below ^^

@philip I think I have found a possible solution/reason for the issue. Many common routers use some type of 2.4ghz to 5ghz switching system so as to use the network more efficiently. It will automatically select which devices get 2.4 and which get 5ghz (usually pc’s get 2.4 and phones get 5), however, the router doesnt seem to know what exactly the Herelink is, so the herelink connects to the network, and detects that it is a 5g network but what it really means is that it is 5G CAPABLE. I ended up hosting a 5G hotspot from my rendering rig and boom; all maps loaded immediately.

If this is indeed a router issue then a bunch of us could test it and if it is confirmed you could possibly add a note to the documentation about this issue.


Hi Stellios,could you please tell me were to change charging to files please

You have to scroll down screen , and then click on charging option and you change it to file transfer.

1 Like

Apple also often have issues with this. The routers that mix the same bands into the same SSID.

There is also some strangeness at times for some with of the IP ranges as well, try to set a totally custom IP range on your router like 10.0.0 onwards.

1 Like

thank you found it im daft blind and silly scotsman lol

@MadRC @philip may I know which type of memory card goes into the herelink?
I see that a standard micro SD card is not the right one for the herelink

You have asked this question all over the place…
please ask once only

Any uSD

@philip thank you for the help.

Also I’m finding difficulty in entering ESC calibration mode.
I am using HERELINK with PIXHAWK 2.4.8. It’s not entering to ESC calibration mode. I’ve tried all method possible. All connections seem to be fine. I am receiving updates from the vehicle also. But not entering ESC calibration. Help us in this regard.

Any new information on this? I’m having the same issue. I’ve connected the Herelink to a dedicated 5G wifi network, changed map providers and followed @Stelios’s steps to input offline maps. The tile sets show up under the offline maps tab, however my map is still just showing a blank white background.