HereLink No Sbus Output After Update

Hello, I had a old HereLink Ground Unit. (bought 2 years ago) I recently bought a new Air Unit. (a week old) I updated both to the latest version using flasher_win.exe.
Ground Unit Update:

Air Unit Update:

Both updates were successful. I started up the Ground Unit, went through the activation steps again and re-paired my ground unit with the air unit. I received telemetry data but no rc data on Mission Planner. Could someone help? All the wirings and the params are correct. If I pair a new Ground Unit (a week old) with the new Air Unit, it works fine.

did you try calibrate your controller and save after upgrade ?

Yeah I had tried that, it worked after putting it in beta

Hi, how you updated to beta?

Hi, nice, how you updated to beta?

just flash the firmware on the ground unit first using flasher_win.exe, following the instructions. then on the activate screen, you will have a register for beta option. if you select that and follow the update procedure, you will be able to update the air unit through the herelink settings app by clicking download, transfer and then update. Just need to pair with air unit first.