Herelink not connecting. Says"Detected 0 radio channels. To operate PX4, you need at least 5 channels"

When connecting with Herelink the pairing part goes smoothly but when i hit the radio calibration it shows the error [Detected 0 radio channels. To operate PX4, you need at least 5 channels].
Herelink is connected with the gcs but the radio part does not seem to connect. the telemetry part works just fine its just the radio part that giving me trouble .Please help ASAP.

@sidbh?

The Sbus cable from the herelink has 2 outputs the yellow and black cable s you need to connect to your FC are the ones nearest the antennae. connect these to your SBUS in on the Autopilot and make depending on which autopilot you use you may need to set a parameter to SBUS instead of RSSI

Bonjour, pareil que Gourav1997 impossible de calibrer les joysticks, erreur idem.
j ai un Herelink avec sbus 1 connecté sur sbus in sur le cube.
help!!! je galère !! merci.

Any solution to this? @Gourav1997 @andre @sidbh @philip
I am also stuck at this issue for a couple of weeks. Please help! :vulcan_salute:t2:

solution to what? this topic is two years old and was solved by connecting the correct s.Bus cable

Hi @philip.
My bad. I couldn’t understand what Andre said.
Anyway, I have tried connecting both the SBUS cables multiple times, but still couldn’t get the Pixhawk to detect the radio.
Maybe I have a broken air unit?

hi,

what is the name of the parameter to change from RSSI to SBUS (for ardupilot) ?
thanks