Herelink radio calibration not working in qground

hello dear pilots
i recently bought herelink and orang cube pix4
i updated everything paired too
i hv telemetry data but not rc in and i cant calibrate the radio in qground control.when i move the sticks nothing is moving…keep saying no channal mapped…
i connected the sbus 1 to rc in on the pix4…really tired of trying and no chance… even in mission planner no radio input in radio calibration tab
hope you guys help me…thank you so much

009647701486237 whats up number
if anyone could help me please contact me

please refer to this image
https://docs.cubepilot.org/user-guides/cubepilot-ecosystem/cubepilot-ecosystem-autopilot-wiring-diagram

it shows how you should wire it up

Hi,

I’m having the same problem. The cube orange and the air unit are wired up as shown in the image. It used to work but now since a while it stops working and I’m having the same issue as Rabar.

I tried it with a Cube Orange and a Cube Black with PX4. QGC in the herelink shows “Detected 0 Radio Channels. To operate PX4, you need at least 5 channels.”, whereas QGC on the computer shows “Please turn on transmitter”.

I have also tried to change to switch the SBUS.1 and SBUS.2 plugs and also the TELEM1 and TELEM2 connections, but no chance.

Both the air unit and the herelink are using the latest firmware.

Thanks in advance.

mate i dont hv wiring problem

ok have a look at the rc setup page then

+1
Experiencing the same problem. The telemetry seems to be working, but the SBUS receiver isn’t being detected, throwing the error “Detected 0 Channels. To operate PX4 you need at least 5 channels”.

I am having the same problem somebody please help me

Anybody found a solution. seems like many people experience a fatal setup error.

Herelink updated to latest firmware. Can connect, joysticks calibrated. SBUS1 is connected, calibration window shows SBUS output. However no RC input in mission planner on ground control when I want to calibate radio I get “detected 0 radio channels. To operate PX4 you need at least 5 channels”.

Did anybody get this fixed? I checked mission planner params and also tried setting it specifically to SBUS. SBUS1 is connected to the RC in. Telemetery is also connected and working.

Thank you, Marius

Did you calibrate your controller in “herelink setting” page?





Thanks for the reply. Yes did that multiple times the joystick calibration in herelink settings. Also tried reflashing the herelink unit and uploading new firmware on the cube. Both the stable as well as the beta plane version. Am really stuck and need this fixed asap as we are doing a launch for a school soon.

Is there a way i can downgrade the herelink firmware? Seems i am not the only one with this problem. Thanks marius

Since I had the mini-board, I needed to cut the bumber on the SBUS connector as the mini-board has the signal on the opposite side, It works now the signal is in the correct spot (Doh…) Cheers :slight_smile: