Herelink radio calibration not working in qground

hello dear pilots
i recently bought herelink and orang cube pix4
i updated everything paired too
i hv telemetry data but not rc in and i cant calibrate the radio in qground control.when i move the sticks nothing is moving…keep saying no channal mapped…
i connected the sbus 1 to rc in on the pix4…really tired of trying and no chance… even in mission planner no radio input in radio calibration tab
hope you guys help me…thank you so much

009647701486237 whats up number
if anyone could help me please contact me

please refer to this image

it shows how you should wire it up


I’m having the same problem. The cube orange and the air unit are wired up as shown in the image. It used to work but now since a while it stops working and I’m having the same issue as Rabar.

I tried it with a Cube Orange and a Cube Black with PX4. QGC in the herelink shows “Detected 0 Radio Channels. To operate PX4, you need at least 5 channels.”, whereas QGC on the computer shows “Please turn on transmitter”.

I have also tried to change to switch the SBUS.1 and SBUS.2 plugs and also the TELEM1 and TELEM2 connections, but no chance.

Both the air unit and the herelink are using the latest firmware.

Thanks in advance.

mate i dont hv wiring problem

ok have a look at the rc setup page then

Experiencing the same problem. The telemetry seems to be working, but the SBUS receiver isn’t being detected, throwing the error “Detected 0 Channels. To operate PX4 you need at least 5 channels”.

I am having the same problem somebody please help me

Anybody found a solution. seems like many people experience a fatal setup error.

Herelink updated to latest firmware. Can connect, joysticks calibrated. SBUS1 is connected, calibration window shows SBUS output. However no RC input in mission planner on ground control when I want to calibate radio I get “detected 0 radio channels. To operate PX4 you need at least 5 channels”.

Did anybody get this fixed? I checked mission planner params and also tried setting it specifically to SBUS. SBUS1 is connected to the RC in. Telemetery is also connected and working.

Thank you, Marius

Did you calibrate your controller in “herelink setting” page?

Thanks for the reply. Yes did that multiple times the joystick calibration in herelink settings. Also tried reflashing the herelink unit and uploading new firmware on the cube. Both the stable as well as the beta plane version. Am really stuck and need this fixed asap as we are doing a launch for a school soon.

Is there a way i can downgrade the herelink firmware? Seems i am not the only one with this problem. Thanks marius

Since I had the mini-board, I needed to cut the bumber on the SBUS connector as the mini-board has the signal on the opposite side, It works now the signal is in the correct spot (Doh…) Cheers :slight_smile:

I’m currently running into this issue.

I have a Cube Herelink controller unit and Herelink RC receiver unit connected to the CubePilot base board with Cube Orange on top. PX4 firmware is running on the airframe components, and QGC on the Herelink controller.

I was able to get the Herelink controller to pair with the receiver, and go through the Herelink calibration instructions. Once I tried to go through radio setup on QGC, I receive the message “Detected 0 radio channels. To operate PX4, you need at least 5 channels”

I used a protocol analyzer to verify the Futaba SBUS messages were coming out of the Herelink RC receiver, on the SBUS output of the receiver, and going to the RCIN pins, (top pin ground, bottom pin data) The messages going through has Ch1-5 @ value 1000, and Ch6-9 @ value 0.

Unsure of next steps to troubleshoot or how to mitigate this issue.

A mi me da el mismo error cuando intento calibrar la RADIO en el menu de QGC, todos los componentes tienen el ultimo software instalado, CUBE Ardupilot, receptor y emisor Herelink. Llevo semanas con este problema, y no consigo arreglarlo. Por favor, si tú has tenido este mismo problema " 0 canales de radio detectados" y lo has solucionado, puedes poner aqui como lo hicistes ?. Gracias

I have same problem.
Are you solved your problem?
Can you help me?

Hi, I have same problem and my sbus Chanel in radio unit not working.
And sbus Chanel output not working.
I can’t understand your solution.
Can you help plz

The cable was plugged in the wrong way. It only fits in 1 way on the mini-board but that was upside down. Make sure the black cable is on the ground

Thanks so much for your fast answer.
I checked my cable but it was correct…