Herelink SBUS issues after update

Hi guys. I am using herelink with cube orange. Everything was working fine before updating firmware. I updated both remote and air unit to :
My orange cube is updated to latest plane firmware
I followed the calibration process meticulously step by step as per videos and it is all showing as calibrated with SBUS out indications correct.

After the update I was only getting SBUS output indication on QGroundcontrol from throttle and wheel (channels 3 and 5). Went through the entire update process several times with no improvement.
At one stage I managed to get all channels to show up in Mission Planner on pc via USB connection and did the Mission Planner radio calibration. After that all channels died (now if QGroundcontrol gives me the no RC channels detected error if I go to the radio calibration screen)

I have tried replacing the SBUS cable and I have checked that I am using SBUS 1 output to RC.

I have checked and changed power cable and power source.

I have tried reverting to a black cube with the same outcome.

At this stage I am assuming my air unit has died, is there anything else I can try ?

How about the HW calibration in Herelink Settings App? Have you go through it?

And the telemetry? Does this part still work?

Yes, the HW calibration in Herelink settings app has been completed, all steps in sequence, shows calibrated, saved the settings, and shows SBUS output correctly. The telemetry is also working perfectly, just RC channels not working.

IMG_2427 IMG_2428 IMG_2429

The QGroundControl screen shows some weird indications for channels out of slider range ?

OK. So I guess the most likely explanation is that my air unit is faulty (most likely a hard landing has caused the progressive fault). I bought this herelink in used condition. What is the process for inspection and repair of the air unit ? I don’t really want to have to fork out $700 for another air unit …

Can you try to connect the Cube to computer and try to do RC calibration there, instead of calibrating on Herelink?

If it still doesn’t work, contact your reseller for RMA.

tried that, doesn’t detect any rc channels. thanks, will try to get hold of a reseller to help me

I am having the same issue, did this get resolved?

In my case, I had fried my air unit

same issue with 2 Rc herelink after update!!!

I resolved my issue by removing the revese ouput on mission planner side. I reveresed the ouput on the herelink side instead this resolved my issue. It looks like a bug in mission planner.

Hi Tyler…. I don’t know if I understood well … I put the 4 channels RC1_reverse (up to RC4) in Reverse and specularly I changed the commands on Herelink but I had no results
I calibrated Herelink (Sbus) and also Missionplanner but … zero !!!
Did you do this and it worked to you?

Yes, i removed all of the reverse settings from MP. I linked my forum below there should be videos j posted.

Hi, I have same problem and my radio unit sbus Chanel after upgrade not working.
Can anyone help me