Herelink Scroll Wheel


I recently successfully flashed both air unit and controller with new firmware and have them paired. My only issue is the scroll wheel wont calibrate and keeps giving this error " the range of scroll wheel is too small, This is a bad rollwheel." If I try moving the wheel left or right like I did to successfully calibrate the joysticks, I do not see feedback.

Is this a bug or hardware malfunction?

Please try to push further to its end. Effective range size of the wheel is around 620mv

I have tried to do that with no success. There are two things that happen when I try to calibrate the scroll wheel using the HW wheel cal or SBUS out Cal. One thing that happens when I do not touch the scroll wheel, It acts like it is getting constant input to the right. The other issue is, when I try to move it, it doesn’t register my input so i can not finish calibrating.

I have tried to flash the firmware again, but nothing changes. I used the firmware suggested on How To Update Firmware - CubePilot. I downloaded the firmware again just incase there was an issue with the file when I downloaded it. I have been wondering if I am using the wrong firmware somehow or there is a bug in it. I get these parameter errors when in QGroundControl.

The error message in QGC has nothing to do with hardware. It is due to newer autopilot firmware connected to older GCS.

If you see the feedback of the wheel changing when you are not even touching it, and tried reflashing firmware, you may contact your reseller for RMA.