Herelink stuck in bootloop (Soft brick)

Dear all,

I have flashed boot.img provided by @Michael_Oborne (link to the file) with a patch from magisk manager to get root access. And the device booted successfully with root access. However, after trying to install and run a root manager app called SuperSU which requires a reboot to take effect, the Herelink device got stuck in bootloop.

With access to fastboot, I have tried following commands with no success to recover the device to its normal state:

fastboot erase userdata
fastboot erase cache
fastboot erase boot
fastboot flash:raw boot boot.img

The standard procedure to recover Andriod devices from bootloop is to do a complete factory reset from the recovery partition. However, there is no stock recovery on herelink, or maybe access to recovery is blocked. I have tried to boot into recovery with the following command: fastboot reboot recovery which fails to launch recovery mode and instead goes back to bootloop.

I take full responsibility for modifying system files and bricking my device. Kindly guide me so that I can recover my device or provide the recovery.img file to allow me to factory reset the device to its normal state.

Thanks in Advance,

Have you tried to re-flash the original firmware again?

1 Like

This worked. Thanks for the quick reply Alvin. Really appreciate it!!