Herelink Throttle problem[SOLVED]

Hi everyone,

I have a herelink station with firmware 0.2.2 and the receiver with the same firmware version. I am using it with a Pixhawk cube black. I have installed the version of Rover 3.5.2.

In the Qground radio control setup menu, after calibrating the joysticks, the throttle stays in the position shown in the screenshots.

When I raise the joystick the throttle goes up, and when I lower the joystick the throttle also goes up.

I have already tried to calibrate the joysticks from the Dial Pad menu.

Here is the param file
rover (3.7 KB)

Thank you

Check the throttle Center in rover as I also had this. I’ll get the pram for you now.

Check the RCX_Trim setting as this should be your centre for the channel. For some odd reason rover is not calibrating center correctly are times.

The x stands for the channel number.

Thanks for your quick response, I have the RC3_Trim set to 1500
I have tried different values ​​for RC3_Trim and it doesn’t cause any changes

I solved the problem by checking in the Joystick menu the options “full down stick is zero throttle” and “allow negative thrust”. Without recalibrating!

Then I forced the RC3_Trim from the Parameters menu to 1500 PWM.

In the radio menu now the throttle appears centered although in the Joystick menu it appears offset.

Now the rover goes back and forth!
Thank you!

Glad you got it sorted. Both things can cause the same issue. Funny mine was the other.

same issue with the new update. any thoughts as the “joystick” menu is gone with the latest firmware for the herelink.

There will be a lot more options in the near future on this.

So tried doing a calibration using QGC for windows and got this error along with the throttle being in a strange spot on the slider.


i have the same problem, what can we do? How can we solve this problem?

Hi there, did you get your issue resolved? I am having similar problems… Throttle is reversed in manual but normal on auto. Please help if anyone has a solution. Thanks

No brother I am still facing a problem, No solution, No help from the forum

Connect your autopilot to computer. Go to the radio calibration page in your GCS.
Is PWM value for throttle reversed there?

I had the same problem after the last update.
I solved the problem like this:

  • I opened Herelink setup;
  • I opened the joystick page;
  • I set RZ to REV (it turns green to the touch);
  • I saved
    After this stage I did the normal calibration in Qgroundcontrol