Herelink Throttle problem[SOLVED]

(cristina) #1

Hi everyone,

I have a herelink station with firmware 0.2.2 and the receiver with the same firmware version. I am using it with a Pixhawk cube black. I have installed the version of Rover 3.5.2.

In the Qground radio control setup menu, after calibrating the joysticks, the throttle stays in the position shown in the screenshots.


When I raise the joystick the throttle goes up, and when I lower the joystick the throttle also goes up.

I have already tried to calibrate the joysticks from the Dial Pad menu.

Here is the param file
rover param.zip (3.7 KB)

Thank you

(Ian ) #2

Check the throttle Center in rover as I also had this. I’ll get the pram for you now.

(Ian ) #3

Check the RCX_Trim setting as this should be your centre for the channel. For some odd reason rover is not calibrating center correctly are times.

The x stands for the channel number.

(cristina) #4

Thanks for your quick response, I have the RC3_Trim set to 1500
I have tried different values ​​for RC3_Trim and it doesn’t cause any changes

(cristina) #5

I solved the problem by checking in the Joystick menu the options “full down stick is zero throttle” and “allow negative thrust”. Without recalibrating!

Then I forced the RC3_Trim from the Parameters menu to 1500 PWM.

In the radio menu now the throttle appears centered although in the Joystick menu it appears offset.

Now the rover goes back and forth!
Thank you!

Herelink radio problem
(Ian ) #6

Glad you got it sorted. Both things can cause the same issue. Funny mine was the other.