Herelink to Mission Planner Connection Issue Over Wifi Network

I am having an issue of not being able to connect herelink to mission planner over wifi when they are connected to the same wifi network. Tried on two different networks and computers. I have followed all instructions as listed in:

I have been able to connect herelink to Mission Planner by the hotspot and USB tethering but just cannot get it to work over wifi. I have opened the UDP ports 14552 in the firewall in both directions. Need to get this to work as one computer is controlling several drones and the hotspot is not suitable in this situation.

I am also having issues with the hotspot. When I have the herelink connected to Mission Planner through the hotspot, everything works including parameter changes, etc. After about 20 minutes, the hotspot quits working and is greyed out. It will not turn on or off. Same with the wifi button. If I put the controller in the shade for a while, the hotspot will begin to work again. Anyone else having this issue?

Herelink has the recent firmware version SRU01200616
Mission Planner version 1.3.74

Thanks in advance for your help,

give your statement, i have to ask what is the ambient temperature where you are, and are you using it in full sun.

the herelink does throttle based on temperature, just like many mobile devices, and will turn off if it gets too hot.

Thank for the reply. The temperature today was about 12C. Not very warm. The controller was used for maybe 20 minutes in direct to semi-direct sunlight before the hotspot quit working. It is pretty weak if that is all it takes to shut it down.

Any advice on my issue of connecting by wifi over? Having a heck of a time trying to get that to work. Not sure what I am missing.

Thanks for the help. -Justin

i was expecting you to say ambient of 40 so i doubt its temperature related then.

are you sure its not something with the wifi network you are connecting too?

as a example i have a herelink connected to the office wifi 24/7 and can stream video for hours at a time with no issue

Just to be clear, I am having two separate issues that may be related.

The first has to do with the hotspot. In use in 12C weather in the sun for maybe 20 minutes, the hotspot shuts down and will not work again until placed in the shade for a while to apparently cool down.

The other issue is not being able to connect to Mission Planner via wifi when both the Herelink and Mission Planner are on the same network. Have tried different networks and computers. There Herelink connects to wifi without issue (unless the hotspot quit working then the wifi does not work as well).

I reinstall the firmware and the issue still persists. Do you think it might be a hardware issue with this unit?

Thank you for your help. -Justin

could you please provide a bugreport when this happens

Hi Michael.
Thank you for getting back to me on this.

I have not been able to fly since the last post. I was able to resolve the issue with connecting to Mission Planner. The router was to blame. A factory reset of the router resolved the mission planner connection issue.

As for the hotspot/wifi shutting down, that has not resolved. I have attached the bug report and hopefully it will have the information from April 22 when the hotspot shut down. Next time I fly and the hotspot shuts down, I will generate another bug report and send it along.

Thanks again, (633.4 KB)

im afraid it doesnt have that info.

a bugreport is only good for either the current session, or the past few mins of the previous session

so if there is any way for you to make it happen, need to do a bugreport directly after it happens, ideally without a reboot in the middle.

Hi Michael. I was able to get out and fly this morning and repeat the hotspot issue. As a recap, this morning’s ambient air temperature was about 10C (50F). After about 20 minutes of flying with the Herelink in the sun, the hotspot stopped working. I lose connection to the computer running Mission Planner. The Hotspot will not turn back on and neither will the WiFi turn back on. When I set the Herelink in the shade for maybe 10 minutes or so, the Hotspot/WiFi will begin working again. I never lose connection with the drone. The issue seems to be limited to the Hotspot/WiFi.

I was able to generate the Bug Report while the RC was still on and connected to the drone. Uploaded below.

Thanks again for all of your help. (942.2 KB)

can you please try the latest beta firmware if you are still having issues? there is a fix for a wifi issue included

Thanks Michael for getting back to me. I was able to update the Herelink and Air unit to the latest Beta firmware and test it out. I had the Herelink setup up in the direct sunlight and air temperature at 80C and the hotspot/wifi never quit working in the hour that it was sitting in the sun. The latest beta firmware has resolved this issue of the hotspot/wifi not working when the RC gets warm.

Thanks again for your help and support. It is greatly appreciated.

1 Like