Herelink update - cannot register device


I’m working on QGC video code updates sometimes and this time I wanted to play with herelink. I bought unit here, in Ukraine from private person (just to save time) - the unit was activated and fully working. Also I’ve key which was used to active it.

I tried to update my ground unit following your fastboot update guide. After updating I was asked to enter the code - I entered this one which was used on the device previously. It did not work.

I checked that my WiFi network is not 192.168.0.x, that time on the device is correct. Also tried on different WiFi network just because it is faster to try than do not - it did not help.

Seller gave me new code and it was also not accepted.

So I’m here. Could anyone help me with activation procedure? At least I’d know what is happening - is this kind of networking problem or something else?

Have you set the time/date and timezone correctly?

Yes, date and time was absolutely perfect - device uses ‘automatic time adjustment’ and most likely syncs date/time via NTP. WiFi IPs were in range of 10.x or 172.x.

Can you try to reflash the firmware again?

Sure, 30 mins.

No, reflashing did not help. Tried both keys.

Chances are it’s still an internet connection thing. Try tether to mobile phone.

Tried 2 different mobile networks (iPhone 12-based hotspot in both cases) - no luck… Tried to factory reset ground unit and other usual Android steps - no luck… Time is ideal… IP was always out of network…

We found that your Herelink was being registered using 3 different keys. Not able to register is the side effect of this.
You Herelink should be fixed now. You may tried to register again.

Thank you! Registered now.