Herelink v1.1 Screen Freeze Issue

Hi @philip @Michael_Oborne

I just bought two new Herelink v1.1 systems and registered them, updated them, did the stick calibration, updated Solex and did all the necessary startup steps.

When I run Solex, I observe a bizarre “Freeze” issue. The screen just freezes at the current frame and never recovers! Sometimes this issue happens within 10 seconds of starting Solex and sometimes within 1-2 minutes. But it ALWAYS happens!

I think this issue is related to the Android interface since every time it had happened to me, it has happened mostly when I pressed any Android touchscreen button like back, or when I swiped the top menu to access any Android feature.

I have also uploaded a video of my issue on Linkedin which clearly shows what’s happening: Herelink v1.1 Freeze Issue - YouTube

My herelink is updated to the latest available firmware, that is, ARU01220804 at the moment.
My Solex version is 1.2.5
Arducopter version on my drone is v4.3.7

When the screen hangs, the telemetry is lost completely, but the RC still remains functional for a minute or so, and then it disconnects too.

I have come across some people who are experiencing a very similar issue, and that too, even after getting RMA. Link to that post: Second defective Herelink 1.1 TX?

Hence it has something to do with the firmware itself. Also, there’s an issue with the Fastboot screen also. When I press Power+D, I get a blank screen only and not the expected Fastboot screen.

I have been using CubePilot products for a long time now, and my previous herelink v1.0 never had any such issues.

These kinds of issues are not what’s expected from a technology leader like CubePilot.

This is a serious issue as the control of the drone would get “completely lost”, and if the drone is flying in Stabilize, then the results can be as catastrophic as you can imagine.

I request you to please kindly look into this urgently, as it happening with a lot of other users also, and because of this, my builds are completely stuck and my clients are waiting.

Let me know if you need any other information or any other log to help you in your investigation.


1 Like


So it has been 4 hours since I am trying to narrow down the cause of this freezing issue. I did many experiments and here’s the summary:

  • I tried many different Android settings combinations with Solex such as with WiFi, without WiFi, with region set as USA, with region set as Europe, with WiFi unconnected but on, etc.
    But with each setting, at some point, I was able to get to the hang issue. Sometimes it froze after 30 seconds and sometimes after 3 minutes, but in all tests, it froze with Solex.

  • Then I tried with QGC. With QGC the issue didn’t come up. I tried to open the top Android menu many times and also tried pressing the touchscreen buttons many times, but it stayed solid! I tried all the pages of QGC while opening the top Android menu in between, but the issue still didn’t come up. I tried for around 15 minutes.

  • At this point, I was sure that QGC was working fine with the current Andoird settings. So I thought to test Solex with the same settings to be sure where the problem is.
    So I disconnected QGC, opened Solex, and connected it to the vehicle.
    Believe me or not, but as soon as I tried to open the top Android menu, the system froze within just 5 seconds of connecting Solex.

At this point, I am sure that the problem lies in the “Solex + Herelink v1.1” combination only since with QGC I am not able to reproduce the issue.

I hope this information could be of some use in your debugging.
@philip @Michael_Oborne @Alvin

Hope I get some resolution on this soon.


Thanks for the thorough testing!! Very helpful!

I’ll tag @kellyschrock and @Michael_Oborne

Hi Divyanshu,

Wow, this is a good find! I haven’t seen that issue here, and would like to get to the point I can reproduce it. @philip both of my Herelinks are 1.0. Is it possible to update one of them to v1.1? It appears the combination of v1.1 with Solex is the issue. If it’s not possible to update one of mine, let me know and I’ll just order a 1.1 unit. Thanks!


Also Divyanshu, if you can reproduce that issue and then capture a device log to send me, I’d like to see what’s going on. It seems like the entire device is locking up.


Hi @kellyschrock
Please guide me with the steps to capture a device log, and I’ll do that and send it.


There’s a “Send bug report” item on the power menu on the device, assuming you have it enabled. If you don’t, you can enable it in the Android settings application.

Hi @kellyschrock

I was just about to sleep in the next 15 seconds when I received an email notification about your reply and I thought to give it a try just for the sake of resolving this issue early.

So I connected my vehicle to herelink and I tried accessing the “Take Bug Report” option on the Developer Options menu. Here’s my experience:

  • The “Take bug report” option gave me 2 options to choose from. The first was the “interactive option” and the second was the “full report” option.

  • Firstly, I selected the “full report” option and nothing happened. Literally nothing. I even tried pressing the power button to see if any “send report” option comes there but no. I thought that it was creating a report in the background, so I recreated the freeze issue thinking that on reboot I’d get the option to share some report, but no.
    On the second try, after selecting the “full report” option I rebooted purposely thinking that on reboot it will start creating a report, so I rebooted but still on the power menu there was no option to send a report. So I thought that it was still creating a report and I recreated the freeze issue, after which there was no option but to forcefully reboot the system, which I did. But still, no option to send a report or anything.

  • So now I tested the “interactive option” on the “take bug report” option. When I selected it, I got a timer-like notification on the swipe-down menu of Android which said something like “Creating a report”. So when it was creating the report, I recreated the freeze issue, but it hanged and I had to forcefully restart the system. On restart, it restarted like nothing happened. No option to share the report or anything.
    Next, I just used the “interactive option” and switched to the Solex screen, and waited till the report generation was completed. When it completed, the notification asked to tap on it to share the report. When I tapped on it, it said “Shell has stopped working”. I retried 3 times but same result.

Utter disappointment. Please let me know what I did wrong. Throughout the process, I couldn’t get any power menu option to share the report or anything, even after the interactive report got generated.

Good night.

Not sure about all that, but “full report” is fine, thanks.

That’s so weird. As you know my Herelink freezes going between flight apps and system functions. But my will freeze with QGC as well as Solex.

Mine freezes if Solex has been running at any point following bootup. If I switch to QGC and have Solex running in the background, strange things happen like joysticks stop registering anything, etc. I’ve not had the unit completely lock up yet, but I definitely have seen bad things. If I simply never tap the Solex app icon, things seem to work swell.

Hi @carltondhouston
Yes, you’re right. Even I faced a similar issue yesterday. I connected Solex and then closed it from the app drawer. Then I opened Android settings and after like 5 seconds, the system froze on the Android settings screen.

Hi @srbell
As far as I understand, the sole issue is Solex. If at any point after bootup, you have used Solex, then even after closing it, it can cause the system to freeze somehow. Try launching only the QGC after the bootup. Don’t touch Solex at all.

Hi @kellyschrock
I don’t know if you’ve read my summary on report generation or not, but I am not able to generate the report on my herelink v1.1 with the steps which I have mentioned in the summary.

If you can guide me with “detailed” steps or some video on report generation on herelink, then I’ll try again.


Yes, I read it. It gave a detailed account of your efforts to generate a bug report and your utter disappointment with the process. All I can say is that the Bug Report feature is an Android feature, not part of any app. What it does is generate a complete system dump in a file that can be examined separately. This may help in finding the cause of the lockup, which (from what I read from yours and others’ comments, appears to be system-wide). I’m not sure how much additional detail I can provide in the process of clicking what is essentially just a menu item, but you might try this:

  1. Follow the steps you typically follow to cause the lockup.
  2. Reboot (sounds like you have to do that)
  3. Click the “Bug Report” item to generate the bug report


Carlton, are you on Herelink v1.1? This sounds like the place where it’s happening. I need to get my hands on a 1.1 unit it sounds like.

Are you able to generate a bug report and send it to me when this happens?



Are you able to generate a bug report for this? It’s not happening for me, but I’m not on a 1.1 unit. Would really like to get to the bottom of this issue.


I think where @Harkhka was getting mixed up was trying to generate a bug report in the midst of the failure occurring which is not possible with a locked up system. You’re asking us to generate a bug report immediately following rebooting from having the issue.

Yes, @kellyschrock I am on v1.1. I will generate a bug report and send it to you shortly. Thank you for your help.

Hi @carltondhouston
If possible can you please also record the steps which you take while generating the report? Looks like no matter how much I try, I am not able to generate it. I’m definitely missing some steps.

bugreport-N2G47J-2023-04-30-22-06-49 (2).zip (985.6 KB)
Here’s one from a week ago.

I thought I’d try using my Herelink 1.1 with QGC, but not sure if I trust it would work. Sure enough, it seems to run without freezing… Until it freezes. Solex will freeze up really fast. Which tricked me into thinking QGC was operational. After 10 or 15min, it will freeze like the Solex app. Back to the 1.0 controller.