Herelink v1.1 Slow Data-Rates


I was able to setup a Hirelink v1.1 Air & Ground Unit using the Ethernet port on the AU, but the downlink speeds don’t cross 2-4 Mbits/s even when they are just 1 metre apart. Uplink speeds are slower, which I believe is expected.

Can you please suggest strategies to achieve closer to 16 Mbits/s?

I’ve used the following setup for the first speed test.

Custom ethernet Cable made according to wiring diagram.

I ran the speed test using the iperf3 tool where the Laptop on the ground-side is the server (receiving end) and the client is sending from the air-unit side. I ran most speed tests over TCP, but UDP also had similar speeds.

Before the test, I had updated the firmware of the air-unit from the ground-unit as well. The following settings were set on the controller.

  • Frequency Hopping ON
  • DL BW 20M
  • UL BW 20M
  • Ant AUTO

Results of full chain test.

As a second test, I eliminated any potential overhead from the WiFi hotspot and ran Iperf3 directly on a GND unit shell. For this second test, the WiFi, Bluetooth, and Hotspot Tethering functions were switched off on the ground unit. Therefore the laptop connected to ground-unit is out of the equation.

To install iperf3, I installed termux on the GND unit and did pkg install iperf3. I ran it using the platform tools adb shell. I’d also tested a different iperf implementation using the “PingTools” .apk, but it had similar results to running iperf directly in the shell.

Test 2 Results

Additional Info:
Output of ifconfig on the GND unit shell.

Apart from iperf3, I tested one-way file transfer speeds using scp, but they were similarly slow as well.

Also, is there a way to do such a speed test between only the air-unit and ground-unit? This way I remove a potentially-faulty ethernet cable from skewing the test results as well. For example, is there any way to stream data from the SD card on the air-unit to the ground-unit?

I’m not sure your test environment but i get high rates


and the other way 10Mbit

and at 20Mbit

1 Like

Some questions:

  1. Can you explain what the lmi40 interface is on the GND unit ifconfig output?
  2. Is the 192.168.0.x subnet supposed to be used instead of 192.168.144.x/24?
  3. In your test screenshot above, is “” a static IP you assigned to the iperf client device connected to the air-unit? In that case, what is the IP of the air-unit interface?