Herelink version and updating

A bit confused about versions and updates. Herelink registered ok.
The Herelink says it’s on FRU01200409. On a 5.8 wireless connection, Herelink says latest version is SRU01200616 and had that going for 3+ hours and still didn’t complete. I was thinking there was something wrong with the wifi but maybe not. Are the updates always so slow to download (like dial-up speeds of 30kB/s). Tried 2 different networks - all slow. IP is not a 192.168.0.xx as I’ve read is problematic.

Tried the download from flasherwin.exe (fastboot mode) says latest remoteunit release is the same FRU01200409 and looks to be taking 4 hours to download. I guess this is pointless since I’m already on that version but I would think it would recognize the existing version and not attempt the 4 hour download.

I tihnk I should be carrying on with the wifi update but why is it so slow? Video demo makes it look like it completes in seconds.
-update- 3 hours later the wifi update said “invalid package” and I’m starting again. This is beginning to look like an update server side issue

The update should be done within a few minutes.
We have noticed that recently the server was somehow being slow, but we have already fixed it.
Are you still unable to update it now?

I got it eventually, certainly sooner than your response :slight_smile: