Herelink Video Stream not working after update

Hello all,

I was very happy because Herelink is getting better and better after every update. I got all my Herelink air units to stream video perfectly from a GoPro 7 Black with the last releases of the firmware. However, I updated two of them like 2-3 weeks ago, and now no one of them streams video. I have checked the wires and I have tested other camera, and nothing.

I am sure I am missing something and the failure is related with the firmware update and me skipping something, Right??

Thank you in advance.


Were they working before you updated them?
If yes, try “reset to factory” from settings and reload the firmware again

Hello, today I tested another air unit that was not updated to the last firmware. It used to work. I paired it to one of the controllers (updated to the last version) and now it does not work (Video Stream). Before, when plugin the go pro 7 Black in the air unit, the image in the go pro screen disappeared, and the Go Pro logo was displayed, 1 second later the go pro logo appeared in the Herelink Screen and the video stream started.

Now, when plugin the camera to the air unit, the screen in the camera turns black for few seconds and then comes back again, and there is nothing on the Herelink Screen.

I think it should be something related with the update. Because all the air units were working perfectly before, and now no one streams video, neither in QGrounccontrol nor Solex. I have tried different micro HDMI cables and nothing.

Please help

That makes a bizarre. Just make sure your GoPro is outputting 1080P 60fps on HDMI.

Do you have a HDMI-microHDMI converter cable? You can use it to display video from computer to air unit, which will work in most of the cases.
This can verify if the problem comes from herelink or hdmi source

No changes were made in the GoPro, I think that the GoPro output is always 1060 fps on HDMI and cannot be changed. I tested 2 GoPro that used to work before, with no changes made on them.

I have just tried, but it does not work. I have no clue what is going on, but I have 3 air units and 2 controllers and I cannot make it to work. And they were all working before.


Maybe I updated the controllers but not the air units, when I try to update the air units I am getting this screen. Maybe when I updated them the same thing happened and they did not update, and now I have different version on the controllers and air units and is causing the problems with the video stream. The air units can however pair with the controllers and I could fly the quad.

I have solved the update problem, I always forget that you have to unzip Flasher_win or it wont work properly. I re-updated 2 controllers and 3 air units. I tried with the go pro in 1080 60 fps and 1080 60 fps and hdmi1 and 2. I could not make anything to work :sob:

Are you using Solex after updating?
If yes, connect a autopilot. Solex won’t start video stream until an autopilot is connected. This is by design.

1 Like

Looks like I have solved the problem. Hard reset and reflashed all the controllers and air units, and got rid of a couple of faulty HDMI cables and looks like everything works again. Thanks a lot.