HereLink with External Monitor for Waypoint Missions

Just curious what’s the preferred method for making the screen bigger for ease of complex waypoint missions? Thinking of two possibilities:

  1. Connect another computer via WiFi
  2. Possibly adding a RFD900X transmitter to aircraft and ground station connected to a laptop. Is this even possible to have two Telem data links at the same time?

Any help appreciated.


1 Like

hotspot on computer works .

1 Like

But with that, it would only cast the video larger, correct? Any way to make the user interface bigger than the standard HereLink screen? I’m told that planning intricate waypoint missions is just a bit tricky on the small HereLink screen.

1 Like

Hi Bobby,
To do that and being able to interact easily with the drone, i think the best way would be to use a computer running Mission planner, connected to the herelink wifi hotspot.
This way you can access everything, map, mission, guided mode, etc… including the video stream witch you can display in MP HUB.


1 Like

Thanks Julien, much appreciated! Was able to get everything to connect except for Video to be displayed on MP.

In Mission planner right click on the HUD > Video > Herelink Video > Enter Herelink ip > click enter
It requires MP 1.3.70 beta or above

A kind of tablet computer would be a good option as Herelink companion

Unable to see a Video tab option on the HUD for MP 1.3.8 or 1.3.9 beta, but am able to on MP 1.3.7??

With the latest MP you should have an option called Herelink Video when you right click and under Video ?

  • Right click the HUD

  • Select ‘Video’

  • Select ‘Herelink Video’

  • The first time you do this Mission Planner may need to download the files required to play the video. Your device will require and internet connection to be able to do this, you may need to disconnect from the Herelink hotspot to perform this step

  • A popup window will open, enter the same IP as you did in the mavlink step and click OK

1 Like

Hey Ian,

So on MP 1.3.7, I see the video menu but when I click HereLink video, it does not do anything. I do not get the prompt that I should. I removed MP and downloaded again, but still not getting the prompt. Tried this both with HereLink connected to PC and without.

With MP 1.3.8 and 1.3.9 I am not even seeing the video tab in the HUD.