Hexacopter AltHold good - Loiter instable

Hello
I built a hexacopter based on a tarot frame.
I did all of the calibrations (I hope so :wink: and also AutoTune 2 times.
In AltHold the copter works fine and flies solid also in Auto flying a mission it is ok.
In Loiter it flies very instable like shown in the video (after 40seconds I changed flightmode to AltHold):

I tried with LiPo on the drone and below, this changes nothing.
When I try to calibrate the compass, often an error occures like here and it needs about 2 minutes to calibrate (I tried in the house and outside):

Cube Orange with Here+ GPS (AC 4.0.3 and latest GPS firmware)
Herelink steering (latest firmware)
17" props
6S 16000mah LiPo

What am I doing wrong?
Did I miss something or do you need more information?
Thank you for your help!

Have you followed the Arducopter tuning instruction?
https://ardupilot.org/copter/docs/tuning-process-instructions.html
Regarding Mag, Have you disabled internal compass? A picture of position of Here+ would be helpful to tell you whether it’s at good position.
Logs are always welcome. They give better idea on what’s happening.

Agreed with @Mallikarjun_SE,

For compass issue : turn off the 2 internal compass, then recalibrate the external one, it will solve the problem.
Loiter behaviour is probably coming from non-optimised PIDs tuning. Read the tuning instructions in details, it will help a lot. You must manually tune the PIDs and get correct behaviour before doing autotune.

1 Like

What I am seeing in your video is not instability but the braking effect in Loiter.

You can tune this to your liking by adjusting the loiter brake parameters.
If you try a longer run in loiter you will be able to lick up that it only happens when you release the sticks.

Hello,
thanks for all help!
I followed the tuning instructions and changed the values to my 17" props.
I changed AUTOTUNE_AGGR to 0.06
I didn’t disable internal compass. Now I think the compass isn’t the problem.
I think it’s more some attitude problem.
Here some pictures where I placed the Here2 (I wrote it false last time - sorry!)


I placed here some logs from today.

First I flew for Autotune and during this flight I made the Loiter Video and it was only the Loiter problem.
Everything else worked great. (Autotune was succesfully finished)
After landing and reboot with the new parameters I tried to start in AltHold (this is the other video)

@mboland Can you tell me which parameter I have to change.

Here you can see the Autotune parameters:

Thanks for your help!

The Stabilize roll & pitch are very low !
These value are most often between 5 and 10.
Maybe try to start at 5 and increase it progressively by 0,5 until the drone has a good behaviour.

Hello,
Thanks for your answer!
I changed the PID to the Standard values and tried Autotune again.
I think the Roll parameters are too low …
Rate Roll P was like I.

What are your filter values?
There are too many logs in the folder. Can you share one good log?

@Julien Dear Julien, the internal compasses are effected by the current carrying conductors and their magnetic fields, that’s why as per my knowledge the internal compass was replaced by a compass in the GPS which is mounted farther away from the main electronics of the drone. So my question is, why is there and internal compass in the Cube to begin with? and if there are built in compasses, then are they active by default and one has to manually turn them off?

Hello
@Mallikarjun_SE thanks for your help and sorry for my late reply.
What do you mean exactly with filter values?
I made a folder called Loiter Log. There is a log from today where I flew in Loiter mode and still had this problem.
If you need more information please let me know.

Thank you!

Vibrations are getting towards the bad category - better look into what’s causing that, usually prop balance.

I would set these and see how it flies:
MOT_THST_EXPO,0.72
BATT_ARM_VOLT,22.1
BATT_CRT_VOLT,21
BATT_LOW_VOLT,21.6
BATT_FS_CRT_ACT,1
BATT_FS_LOW_ACT,2
ATC_RAT_PIT_P,0.15
ATC_RAT_PIT_I,0.15
ATC_RAT_PIT_D,0.007
ATC_RAT_RLL_P,0.15
ATC_RAT_RLL_I,0.15
ATC_RAT_RLL_D,0.007
PSC_ACCZ_I,0.28
PSC_ACCZ_P,0.14

Also I just noticed your motor outputs:
You CW motors are generally working harder than your CCW motors, indicating a physical yaw bias. Twisted motor mounts or flexing arms are common causes.