High Mavlink loss rate


I have no problem flying, telemetry or video link but when I check the mavlink section in qgroundcontrol I see %60-%80 loss rate. Is this a problem? What is the acceptable range?

1 Like

60-80 loss rate is very high

Can you try to change serialx_protocol to mavlink2?
Is the loss rate high when you’re connecting with usb cable?

You may learn more from this discussion. Looks like the problem is similar

No, when I connect with usb, there is no loss. It happens when I connect with herelink. So whats the normal rate? I will try mavlink2. Btw I am using px4 software.

You may try to turn off any nearby 2.4GHz signal source

Hi, just tried mavlink2, no change. Tried to turn of wifi which is 2.4 ghz, no change. Still geting %60 loss rates. Also I use beta qgc on herelink.

I guess there is a message failing in mavlink router.
If you can get a tlog, we could check it manually.
Can you try whether this happens when using ardupilot as well?

Is this problem has been solved as i am also getting the same issue with my 4.0.3 arducopter firmware drone ?

This should have fixed in current beta.