Horizontal speed between points is limited

Hello everyone.
Flight speed of our copters has become limited for some reason.
Previously, we could set any speed in settings and copter slowed down only to have time to gain altitude (we fly with a terrain following), but kept speed on more or less flat terrain. In particular, we usually fly at speed of 9-10 meters per second.
This year, our copter began to limit horizontal speed strictly depending on distance between points on a profile. For example, if points are located 30 meters apart, then speed will be no more than 6 meters per second. If there are 40 meters between the points, then no more than 7.2.
It was not possible to increase its speed either by the “DO_CHANGESPEED” command or by manually changing the parameter WPNAV_SPEED.
We do not have any speed limits enabled (or I did not find these params).
Сlimb is small.
What caused this limitation and how to get around it?
Is it due to our inattention (and, therefore, it can be configured) or with some changes in a new firmware?

My setup:
Cube Orange (Arducopter V4.1.5)
Tarot x6 frame
2x Here3 gps
Xrotor 50A esc
T-motor mn-501s kv300
30000 6s lipo

Hello @Avvaron

It is pretty hard to guess something without having a log or a parameter list.

What exactly triggered this strange behaviour? It was a SW update? Or several parameters changes?

Try to check the parameters of your drone today to a list of when the problem wasn’t there, it can give you some insights about it.

As you said, longer distances leads to higher speeds, so check if your WPNAV_ACCEL can be misconfigured, maybe your drone is not able to accelerate enough to reach this navigation speed you want.

This behaviour is not triggered by any event, it’s… It just is in auto mode. Only thing that has changed is firmware version.
We tried to put last year’s settings, which worked fine, on this year’s copter, but it didn’t work.
We checked WPNAV_ACCEL, i will check again, but I feel like that’s not the problem. Drone reaches 6 m\s speed very quickly, long before the next point and then flies at this speed.
I will attach our parameters to message.
DaddyDragon6ms.zip (5.1 KB)

Hey @Avvaron

Some considerations about your parameter list:

  • AHRS_EKF_TYPE is 2, showing that you are using EKF2, but it is highly recommendable to change it to EKF 3;
  • The same for EK2_ENABLE and EK3_ENABLE parameters;

Despite this fact, really did not find something that could explain this.

About it, your current WPNAV_SPEED is 650, which is consistent. Try to use a DO_CHANGE_SPEED mission command with lower speeds (like 3 m/s) to check if your drone is really executing the command.

Sorry for a long answer, tomorrow I’m flying on a business trip in the north to a village without access to the internet. I would definitely like to continue this discussion later, in 2-3 months.