How to set parameters for Cube Black and Cube Orange for yaapo telemetry by S.Port

Hi can anyone provide me parameters which I have to change to get telemetry by yaapo telemetry script, sport cable from aliexpress, FrSKY Horus X10 express with open TX software and Archer Gr8 receiver… I tried all setings from arducopter wiki but without success.


the only parameter you need to change is setting Serial1_Protocol to 10 (assuming you are using Telem1).

After a reboot you should get the telemetry data.

Sorry but doesn’t work :frowning:

Are you using the Telem/UART -> S.Port adapter?

yes I am using this adapter. Maybe there is something that I can change in Archer GR8 receiver ?

It’s supposed to be that S.Port is S.Port, regardless of the RX. Which pin are you using?

Yes I am using this pin and GND on Archer and on Cube side I am using PIN #1 VCC, PIN #2 MCU_TX, PIN #3 MCU_RX, and GND.

I think cable is ok. I checked 2 cables and telem 1 and telem 2 port. Images of my test setup:
Sensors from Archer are visible. They are discovered : VFR, RSSI, RXBt, A2, Alt, VSpd even when S.Port is not connected to telem port. So maybe this receiver is in F.Port mode ?

Your GND Cable is connected to AIN2 instead of “-”.

If you move it to “-” (GND = First port on the left of the Archer GR8) than everything should work.

1 Like

I changed the GND to 1 correct pin but it didn’t help

I also changed options of receiver Turn OFF Fport 2 and F.port 1 doesn’t help…

Beside Open tx (2.3.11) which is installed on my Horus and Yaapo telemetry script (1.8.1) do I have to install something more on my transmitter ?

Theoretically you dont need the external converter with Cube Orange, and I would try:

Didn’t help. Please watch maybe I am doing something wrong:

Hi is there anyone who has yaapo telemetry on this new Archer receivers by S.Port or F.Port ?

I get the telemetry but only by F.Port without special inverter cable. I just connected cable from S.Port to Telem1 and set:

I had to also upgrade Arducopter firmware in my Cube Orange to 4.1.0-FIRMWARE_VERSION_TYPE_DEV
I also set in GR8 options FPort and Fport2=enable

I found that if I set on other SERIALs PROTOCOL=10 Fport telemetry stop to work.
Other SERIALS must be set to something different than:
Passthrough FrSky Telemetry Protocol
Is that normal ?

I finally also found solution to connect Cube Orange by s.Port and special aliexpress cable. Everything works on settings:
but others Serial protocols can not be set to=10
Only one SERIALx_PROTOCOL can be set to 10
Also in Archer GR8 Receiver Fport and Fport2 should be disabled in options.

1 Like