IMU3 Failure

I have an IMU3 failure in a Black Cube.

It seems it was causing this erratic zig-zag pattern when climbing and descending altitude. The lines should be smooth?

I understand you can disable IMU3 by doing this?

• INS_ENABLE_MASK = 3 This makes Copter only detect the first 2 IMUs.
• INS_USE3 = 0 This tells the attitude control system to not use the third IMU (if detected).
• EK2_IMU_MASK = 3 (or EK3_IMU_MASK). This tells the EKF estimator to only use the first 2 IMUs.

If I recall correctly they went to the moon with one INS system so a drone with two IMUs should be OK?

Any help or recommendations would be appreciated!

You can surely disable the IMUs.
Maybe @philip can help.

Do not fly this vehicle!

I don’t know what is causing such extreme readings, but bypassing it is not an option

Return the cube to your reseller and get a new one.

The INS to get to the moon was not a men’s device.

Again, do not fly this.

Thanks Philip!
Grounded and busy loading up a spare replacement cube.