Irlock bad vision position


I cant get irlock working correctly on Cube orange. I managed to make it work in the past with cube black, and i used same settings now but i get bad vision position every time and also i see PL heal at 0 in logs.

Lidar is working fine and settings in Pixymon are also correct, i can recognize target very well in pixymon but it seems like it doesnt transmit data into cube. IrLock is running sw version 1.0.1

I think it might be faulty IrLock module (used different with cube black in past)

Im attaching logs and param file, maybe someone will figure out whats wrong with it.

Google drive folder with logs and params

Good Day,

Thank you for your message.

The Autopilot and IR-LOCK Sensor are not communicating. (Heal = 0)

If the IR-LOCK Sensor can successfully connecting to your PC via Pixymon, then it’s probably not a hardware issue. Please follow all steps in the tutorial again, and double-check the wiring (and check another log).



Thank you for answer.

I know about that irlock and autpilot are not communicating but i dont know why.

I did check wiring (tried 2 different cables) and followed tutorial step by step but no luck so far. Also tried modifying PLND_BUS parameter but that didnt help either. All logs are showing HEAL at 0.

I just tried to set it up on bench with cube black and i still get PL HEAL 0 (yes, lidar was connected as well, got readings from it). Exactly followed tutorial, flashed everything once again but still no luck. so there probably is problem with irlock being not able to communicate with autopilot.

Also i noticed that sometimes when i power drone on that led on irlock keeps shining white and it doesnt even change color to red when detecting target. But it happens random from time to time and i cant seem to repeat it on purpose. In other cases it just blinks few times on startup and then there is slightly visible blue, green and red color inside of that led which changes to red when detecting target.

Including photos of LED

You are still successfully connecting to Pixymon?

Hi. I was stumped for a long time because I couldn’t get Irlock working with my cube orange, while it was working fine on Pixymon.
So after a lot of digging around here is what I found:
Go to Pixymon software -> configuration tab -> interface
make sure the “data out port” is set to “1” for me it was 0.

Then ArduPilot side, I set PLND_BUS to 0 (or 2/3) I can’t recall, I’ll check again… but it started working after that. As a side note, prec landing docs are now outdated at the ArduPilot end… I am working on it

Yes, everything seems to work in Pixymon, i can see raw video and it detects target just fine.

Data out was set to 1 whole time. PLND_BUS is 0 whole time as well but im gonna try it with 2 or 3 and will let you know if it helped or not.

Thank you for the feedback.

IR-LOCK’s tutorial includes the following step (image below). Clicking this button will automatically set the data out port to 1, if the correct sensor firmware is installed.

The PLND_BUS selection will definitely affect the sensor communication.

I followed tutorial step by step but it still doesnt work.

Today we recieved new irlock unit and with the new one everything works, im able to get heal 1 finally. So the old one is probably faulty.

Thanks for the help everyone.

I have the same problem. After reading this post, I tried setting > Interface > Change the connection from Arduino to I2C. That’s how it works. Also the connection of the wiring is different from pixhawk.

I rewired according to this picture.

Now it works.

Where did you change the setting from arduino to i2c ? Because i dont see anything like this in pixymon. For me new irlock unit solved the issue

Yes its in the pixymon software. Under settings. Your unit has to be connected to see the settings.

@gwm @Adam_Svacek
Thank you for your message.

The sensor automatically changes to ‘I2C’ after installing the sensor firmware and clicking click ‘Restore default parameter values’ (Step [1] in tutorial).