Issue With Lightware Lidar

(Akshay Yadav) #1

Hi,

I am using lightware LW20B and LW 20C lidar as a range finder and having issues with it.

initially when I mounted 1 lidar facing downward and setting parameters as shown in Ardupilot website

http://ardupilot.org/copter/docs/common-lightware-lw20-lidar.html

It works fine and has no issue but when I bring the second lidar as right now Pixhawk cube can support two lidars so to test the deviation between both lidars and barometer I found many issues.

  1. Sometimes board just freezes and do not respond and not powering up GPS, lidar, telemetry and other sensors which happened quite of times.

  2. I have connected both devices on Telemetr2 and GPS 2 port and sometimes all of a sudden anyone of lidar shows erratic value and stop working until it is lowered to the height where it has stopped working.

Tested for different altitudes can be seen in Images.

  1. I tried to switch the ports and still, the problem persists. Sometimes even when using one lidar it stops showing altitude value and needs to restart the pixhawk.

I don’t know whether it is a flight stack issue or Lidar issue.

kindly let me know as I am planning to buy more Lightware lidar but not procuring right now because of this issue.

I am using firmware 3.6.10 version.

Kindly let me know if others also facing same issues.



#2

@tridge? I believe this was fixed in master? Or am I thinking of another issue?

(Akshay Yadav) #3

Hi Philip,

I have not tried with external power as power through pixhawk is limited for sensors but think it might not be the reason for erratic value. Should I try that and let you know the result?

Also, I was not able to connect any of these lidars through i2c port although tried every possible step but it is not responding to i2c but works in serial.

let me know how to figure that one also?

thanks a lot in advance.

#4

Use serial, and try external power.

#5

Looks like you have an RFD900 connected to serial 1? Is it powered externally?

(Jason Yu) #6

I have an LW20/C and I also had an issue with I2C. Following this guide fixed it for me.

1 Like
(Akshay Yadav) #7

No, through pixhawk only but will try both scenario and will let you know

(Akshay Yadav) #8

Hi ,

Tried this multiple times still not responding.

#9

You must power RFD900 externally.