Issue with mission planner

#1

After I downloaded the latest MP I get the below message.
I have rebooted, uninstalled & reinstalled the program and it keeps crashing.
I noticed this as soon as I loaded the cubeblack parameters. When MP tries to send a error message It tells me could not send message & I have no internet connection.

I have not loaded the cubeblack firmware yet but I am stuck here with MP crashing.

Any help would be appreciated & thank you.

#2

I just restarted it 3 or 4 times it worked

#3

And I moved it to mission planner group

#4

I have restarted it like 15 times now it keeps crashing. How & what do I move to mission planner group. I am sorry I do not understand.

#5

I can run MP. The issue I am having is when I am connecting or loading firmware

#6

Do a check for updates. If that don’t help hopefully @Michael_Oborne can help

#7

Have you tried rebooting the PC after install ?

If that dont work try deleting the install and downloading it again.

1 Like
#8

Also did you us the msi File to install (it’s the only way to get updated drivers

#9

Yes I used the MSI file and have rebooted after install.
full disclosure I had radio link MP installed too. I think it may have something to do with the driver for radio link. I have deleted the RLMP but the driver is still on.

#10

Untitled4

If I ignore the warning I can get to this point after attempting to load the Cubeblack firmware.
I have saved it to my desktop.

I have tried uninstalling every driver and program I can find, then rebooted and reloaded MP. Still I have the same results. Trying to figure my cube out seems daunting at this point. Before this last update I had about 30 missions completed with 1 glitched flight. MP had been working fine. Now I am really stuck.

QCG seems to but I have not used this software before. Is the hex firmware ok for the CUBEBLACK? Probably not I guess…I apologize for my lack of knowledge here there is a bunch to go over.

#11

Remove the radio link fraud version…

Check your antivirus isn’t doing anything stupid.

Reload from the MSI.

Don’t load “specific” cube black, load via the normal method, and let Mission Planner check.

When it asks, tell it yes it’s a cube black. (Assuming it’s a Hex/ProfiCNC cube)

#12

I have removed the fraud version. I only bought it to put on a 350 & practice my Mission Planning. Yes it is trash and I wish I never installed it as it was very hard to remove. I have a 800 hex with a New Hex/ProfiCNC cubeblack, the Here2+ RTK & drotag for the sony a5000 camera. Everything worked for a few weeks down to the 8th digit of a minute for tagging.
I have MP on 3 computers. My windows 7 pro PC, a cheap windows 10 tablet and my Wife’s Windows 10 laptop.
My PC is the only PC that has installed the fraud version and the only one that MP crashes on.
The tablet has a slightly different version and will not show a load firmware tab. Only the wizard is available on the tablet and it will not load “error loading firmware”. I have tried several times here too.
I am afraid to connect the cube black to my wife’s laptop because it works and set for her rover.

QGC worked on my PC. I loaded firmware and went through all calibrations with no errors. The software is new to me as of today so I am not going to just go fly but I am hopeful. Should I trust this for a test flight in a very safe area?
Thank you for the way HEX has handled the cubeblack situation, I still feel much safer with your products.

#13

the error you see here is a corrupt firmware download. something is caching a bad file download