Issue with upgrading firmware of herelink over usb

I have a new herelink, and it is needing a Usb firmware upgrade, but I download the upgrade file cmd line tool for firmware update from the current docs, (for mac), and it keeps spitting out this error:

Last login: Tue Jun 1 08:46:44 on ttys000

The default interactive shell is now zsh.
To update your account to use zsh, please run chsh -s /bin/zsh.
For more details, please visit
/Users/solomonsinger/Downloads/flasher_mac ; exit;
Solomons-MacBook-Pro:~ solomonsinger$ /Users/solomonsinger/Downloads/flasher_mac ; exit;
Looking for Device…
Found Unit Type: remoteunit

Downloading required package…
Traceback (most recent call last):
File “urlgrabber/”, line 1583, in _do_perform
pycurl.error: (77, ‘error setting certificate verify locations: CAfile: /usr/local/etc/openssl@1.1/cert.pem CApath: /usr/local/etc/openssl@1.1/certs’)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “”, line 265, in
File “”, line 73, in download_package
File “urlgrabber/”, line 828, in urlread
File “urlgrabber/”, line 1298, in urlread
File “urlgrabber/”, line 1170, in _retry
File “urlgrabber/”, line 1148, in _retry
File “urlgrabber/”, line 1281, in retryfunc
File “urlgrabber/”, line 1346, in init
File “urlgrabber/”, line 1695, in _do_open
File “urlgrabber/”, line 1833, in _do_grab
File “urlgrabber/”, line 1829, in _do_grab
File “urlgrabber/”, line 1678, in _do_perform
urlgrabber.grabber.URLGrabError: [Errno 14] curl#77 - “error setting certificate verify locations: CAfile: /usr/local/etc/openssl@1.1/cert.pem CApath: /usr/local/etc/openssl@1.1/certs”
[5156] Failed to execute script flasher
Saving session…
…copying shared history…
…saving history…truncating history files…

[Process completed]

This error happens for both air unit and remote. please help! I cannot get the firmware updated, as it seems to have a unauthenticated or error setting certificate. i have downloaded it several times to see if it fixes anything, but it is the same.

I look forward to your reply!

Solomon, UAS Technology Instructor, Lane Community College

Have you unzipped the folder? Did you execute the executable without unzipping it?

Yes, I unzipped the executable, as you can see with the posted text, it was running, searching for devices, and successfully connected to the devices. But then it runs into a problem with the executable when it tries to run line 77 of the executable… ‘error setting certificate verify locations: CAfile: /usr/local/etc/openssl@1.1/cert.pem CApath: /usr/local/etc/openssl@1.1/certs’

That looks like a pc issue. Please try on another computer.

I tried a windows and it worked fine. Perhaps there was something with my computer, or the mac version of the bootloader executable. I got it solved though. Thanks!