Issues connecting to new purple cube

#1

Hello

I have a new purple cube and cant connect to it using the latest qgroundcontrol or apm-planner on my mac. Do I need to use a beta version on private source or?

Regards,

Anders

#2

No need for private anything or beta.
Are you loading CubePurple firmware? Do you have parallels? Or any way to run Windows on that? Mission planner is my recommendation for your GCS

#3

I cant even get to the loading firmware stage.

I cant connect to the cube using any software on either mac or windows. It shows up perfectly in the device manager on both platforms.

#4

I DFU’ed the cube manually via stm-tools on mac and from there I could flash the firmware. It connects to all ground station softwares on mac and windows now. The cube comes without any firmware installed. It works now