Issues with Herelink and the Alta X

Hello everyone pleasure to meet you all I’ve learned a lot from reading posts on my journey to use the Herelink on the Freefly Alta X.

So far I have configured my Alta (on the latest version v1.3) and connected the Herelink air unit to the external telemetry port. PX4 reads this port as Telem2 (conflicting with the documentation from Freefly). I also have a FRX Pro installed on this Alta X with that occupying the Telem1 port.
Using the FRX I can see that while powered on I still have a good SBUS connection as my stick movements reflect over telemetry on the FRX Pro connected to my laptop, however telemetry is not available on my ground unit. The baud rate I am using is 57600 on each of these ports, I have tried a number of different baud rates/telemetry modes without success.

In fact the only success I have had getting telemetry to the Herelink ground unit was very short lived. I was sitting here at my laptop with the radio and drone both powered on, and suddenly the telemetry connected to the ground unit without any change to the parameters. The ground unit tried to get all of the parameters downloaded but failed halfway through and disconnected again. This has happened a few times so far in the last few days of testing, once using a 38400 baud rate.

I should also note that I bought a separate Herelink and tested another ground and air unit with similar results.

So my questions for you all:
Has anyone else tried connecting the Alta X with Herelink?
Does the FRX Pro conflict with the Herelink?
What could be causing this intermittent telemetry issues on my Herelink ground unit?
Would I need to use the other internal telemetry port for the air unit? (removing the FRX Pro entirely)
Why wouldn’t Freefly support Herelink integration on the Alta X when their new drone will have it?

Thanks everyone for your time! Here’s hoping to get to the bottom of this one.

This has happened a few times so far in the last few days of testing, once using a 38400 baud rate.

Herelink works at 57600 baud rate and mavlink protocol. You may check your serial settings in your autopilot.

Does the FRX Pro conflict with the Herelink?

I googled and found that FRX Pro works on 900MHz, while Herelink works on 2.4GHz. So I think they won’t interfere each other.

Hey Alvin thanks for looking into this with me.

I have been using 57600 baud for most of my testing but just haven’t gotten a stable telemetry connection. Any other ideas for me? I think soon I will try and remove the FRX Pro and use that telem1 port for the Herelink it will just take a lot of work to repin the connectors.

Thanks again!

Is your TELEM2_PROTOCOL set correctly ?
you should have “1” (corresponding to mavlink)

I can’t seem to find the TELEM2_PROTOCOL parameter in the QGC full list. I attached a picture of how I configured my mavlink parameters. I have also set serial ports to 57600.

Could this be because the firmware from FreeFly removes the TELEM2_PROTOCOL parameter?

I guess you should change the bit mask on MAV_0_CONFIG if you’re on PX4?

Yes I have tried setting MAV_0_CONFIG to enable telemetry on the Herelink. Unfortunately this forces the FRX Pro to lose communication. Herelink is connected to the external port reading Telem2, and the FRX is connected to Telem1, the internal UART connector.

I have also tried outputting MAV_1 to the same telemetry port with no success. Unfortunately I’ve received confirmation from some other ALTA users facing the same problem. Thanks for all your help so far. Will update more if we have a breakthrough.