Jetson Nano communication issues


I’ve been trying to use a Jetson Nano as a companion computer and run into some problems when I updated from a Cube Black to a Cube Orange. Both are running the same Ardupilot firmware, yet a lot of messages are being dropped on the Cube Orange alone, making logging impossible.

I’ve fumbled a bit with the serial parameters on the Ardupilot and found that checking RX, TX pull down and RX, TX NoDMA boxes improved the communication, but it did not solve the underlying issue, and unfortunately I still don’t have access to the GPS messages I need.

Lastly, I have also tested the serial communication with a Raspberry PI, and it worked on both the Cube Black and Orange, so the problem seems to be just the particular combination Jetson Nano - Cube Orange.

All the communication is being handled by MAVROS.

Has anyone worked with this particular combination and got it running??
Thanks in advance!

Which port do you use for their communication?
Maybe the serial settings(eg: protocol/baud rate/etc) are incorrect?

Sorry I forgot to mention it in the original post! I’m using the Telem 2 port and the exact same serial settings in the Cube Black and Orange, with the communication problem only appearing in the Orange one!

I have also tested this in two different Cube Orange controllers, so I know that it’s not just one faulty unit. Any more ideas where the problem / difference may be coming from?

I use a USB to serial converter (FTDI ) on the Jetson Nano and it generally maps under /dev/ttyUSB0.

Could it be the tty port name are different for black and orange?

I will order a USB to serial to try this route! Thanks! And are you using MAVROS or any other tool?

I don’t believe its the tty port name because they do connect, as in the jetson receives a hearbeat, (irregularly) receives some IMU messages and I can even send some vision position estimates to the flight controller.

However, at the same time I see lots of messages of the type “request param timeout” or “wait ack timeout” with all the remaining topics with flight controller messages, for example with gps or battery information remaining unpublished. This is what leads me to believe that the serial communication is not functioning as it should, and as it did on the Cube Black.

USB works fine @921600 bps on both Mavlink and MAVROS

What baud rate are they using?

I chose 921600bps in both the Black and the Orange (and on the Jetson of course)! I have also tried different speeds, starting from 57600bps just to make sure it wasn’t a speed issue but without luck.

And great that it works with MAVROS! I am now waiting for the part to arrive to try this route, hopefully it will be the perfect workaround :slight_smile:

Can you try if it works on telem1? Just in case telem2 has problem

Also, you may try to swap their carrier board

I just want to confirm that it worked with the converter method, so its probably some particularity of the GPIO pins of the Jetson. Once I had the USB to TTL adapter, it worked right away.

Thank you so much, to both of you!

1 Like