Joystick calibration fail


I was using my herelink almost one year. But something happened recently that I can’t calibrate my joysticks. It’s updated to the last firmware. I follow instructions of the HW JS CAL menu, but Can’t move the black circles to the red ones. Any help?

Have you followed the instructions that show that part does not work until after you finish the calibration.

The Box on the right is the test after completing the calibration.

Please see this on the docs pages


Yes, I did the first part, even it says calibrated on the left side with green. But the circles don’t move. What can cause this? I even did a factory reset but didn’t worked.

Ok that’s not correct.

Can you try re flashing the latest firmware again and make sure after it’s done the time, data and location settings are correct.

Some have resolved this with a couple of flashes and it’s then recovered.

Otherwise you will need to speak to your reseller.

What do you mean by correct data and location settings? Whats the default config for them? I tried flashing the firmware 2 times no luck so far. Is this a hardware or software issue? I never had a crash with remote so my guess is software issue? I flash the remote and update, but when I go to the joystick options It says in green laters calibrated. I guess this is odd.

The whole thing started when I try to connect herelink to the mission planner on a laptop, I believe. On the laptop I had a playstation joystick connected and enabled it. On the autopilot PX4 firmware was running and on the herelink qgroundcontrol was running. Than suddenly the joysticks of the herelink stopped working… Been trying to make this work like 10 hours but this is becoming very frustrating, I must say.

Chances are it’s a failure and I would speak with your dealer.

With the setting I simply mean on Herelink make sure the location is set correctly in settings and that the time is also correct.


Thank you. My dealer is Heliengadin. I allready send an e-mail as you suggested. So I send the unit and they repair?

we just answered your email.
Please do send back the unit to us at the address specified.