Large Hex tuning help needed

So here is the rundown. Currently in the process of tuning a large/heavy hex. I have gone through the steps on mission planner for setup and first flight ect. I’m at the point of notch filtering & PID Tuning. In Altitude Hold the drone is very stable and smooth (no oscillations to speak of). Now in Loiter I’m getting a bit of a pendulum effect. Which I am to believe that it is caused by low PID’s (slow adjustments) I have uploaded the flight logs for the ALTHD flight also the LOITER flight to see what can be adjusted to help prevent/ mitigate this this slow response. I have had great success in the past with smaller quads that are more agile. But this big hex is stretching my technical knowledge a bit. For clarification here is a breakdown of the full build.

HEX 1600mm motor center to center
T-Motor U10II 100KV
Alpha 60v 6-12s ESCs
T-Motor 30.2x9.9 folding carbon props
Here3 gps (dual)
Herelink Blue & Blue Airunit
Cube Orange+ on ADSB Carrier
Mauch PC4/V3 w/PL-Sensor
17000mah Max Amps 10s 15c 629wh battery
full carbon fiber construction frame (very ridged)
min_TOW 13.8kg
max_TOW 19kg

(.bin file)


(.bin file)



Any input or review of this is greatly appreciated. Don’t really want to test durability through crashing it. The next flight (weather permitting) will be with (FFT) on and ALT HOLD to verify if I’m getting and vibrations that need to be tuned out via “notch filter”
I know this is a lot of info dump, but I would rather be accurate than vague. Thanks again for the help.

I’ve checked over a log and your parameters.
Z axis vibrations are a little high - check everything is secured OK, and nothing is touching or pulling on the flight controller - wiring in particular.
X and Y axis are good.

First set these and reboot the flight controller:

INS_HNTCH_ENABLE,1  // write this then refresh params to see the rest

Check your other FENCE parameters, radius and altitude, to ensure they are appropriate for testing or suit laws. Enabling the fence has the effect of NOT allowing you to arm in any flight mode until there is a good GPS 3D fix and Home can be set - it seems to take a while at first but you get used to it. You dont want this beast thinking home is in the Sea of Japan.
The GPS params select a limited number of constellations to improve the update rate. You could also use a value of 7 instead of 67, whichever gives you the lowest reliable HDOP.
The pilot throttle behaviour parameter is because you have a spring-centered throttle, not a critical thing but nicer than not setting it.

The MOT_ parameters are where the fun starts!
The PWM values are because that’s what Alpha ESCs use and they cant be calibrated.
The thrust expo value is because those ESCs mess with the thrust curve a bit and 0.6 will be OK as a starting value - it may need to be changed down to 0.4 and that’s what a lot of people use. Either way anything over 0.8 is way too high, and I’ll get the Initial Parameters calculator fixed.

Since changing those PWM and expo values, you need to get into MissionPlanner motor test and redo the MOT_SPIN_ARM and MOT_SPIN_MIN values before the next flight. Use it to:

  • Check and set the lowest reliable, smooth start up percentage for MOT_SPIN_ARM (eg: 8% = 0.08)
  • Now add 0.03 to that value and set it as MOT_SPIN_MIN (eg: 0.08 + 0.03 = 0.11)

When you do the next flight, the hover thrust value will need some time to relearn, so just be aware the altitude may appear to hunt and require some throttle stick inputs for a short time. Dont do anything adventurous, just hover and try some gentle pitch, roll and yaw movements.

Let’s see that log file and we should be able to refine the notch filter and more.

1 Like

AS USUAL You sir are a great wealth of knowledge!!! Thank you for the input. I will adjust and re-fly. Do you recommend for log and testing purposes ALT HLD or LOITER?

If there is the possibility of instability you are better to start in Stabilise mode so you can land immediately, but otherwise AltHold is good, and if stability is good the use Loiter too.
Once the copter is reasonably flyable, AltHold and Loiter in the same log is useful.

Well that didn’t go as planned. Put it up for about 14sec and it immediately started a toilet bowl. Set it down (hard) suffered a loss of two sets of props. :frowning:
Here is the video and log. Open to suggestions

Very sorry to hear about that.
I’ve seen a mistake in the parameters I gave you:

These are reversed and should be


This probably contributed to the instability and crash, and I apologise for my part in that.
Excessive bandwidth in the notch filter adds lag to the PIDs, and the very low frequency would filter out valid movement.

Other than that I see nothing wrong with all the parameters you have in that log.

I’ll adjust that back up. And once new props are in we’ll get it back in the air. Also I had some feedback that on the PID values that the default should be .135 and it is .1 should this be set to the default or left alone?

Leave the ones you have for now.
With the larger copters it can be worth while doing the VTOL Quick tune script (it doesnt just apply to quad planes)
It will set some basic PIDs to improve fly-ability, then you can dive into details or Autotune for a more complete solution.

Good evening Shawn,

Well props came in, and was able to gain a successful flight. Here are the logs. I have adjusted the P,I, value up from .10 to .11 and feel that its still sluggish but far better. and the inversing those two ins_ values did help lol. So let me know what you see/ think. Before we go further with PID adjustments, and then auto tune. As always thank you for taking the time to help me with my lacking knowledge.

Try increasing these:


these shouldnt have any adverse effect, just make it a bit snappier.
Then you could tentatively try:


Start in Stabilise mode so you can land quickly if required.
If that’s OK I’d probably give the VTOL-quicktune script a go - some just use that and dont even do an Autotune or further manual tuning.

1 Like

The harmonic notch filter is not making much sense now…

Disable the 2nd notch
and adjust the primary notch filter just a fraction:

(I’ve checked for typing errors too!)

1 Like

:joy: I appreciate this info. After these adjustments I’ll give a quick flight to verify. Then upload. If all looks solid then I’ll dive into the vtol script. Just gotta love running and figuring out new builds on unfamiliar hardware. I’ve built numerous quads and hex but all with KDE motors and ESC’s. all of those i just went deep into PID tuning and sent them, with no adverse issues lol. But this one is proving to be a far more in depth run.

Good morning,

Here is the latest flight log and video. Turned off the 2nd notch filter and adjusted the 1st as informed. Turned the ATC_ values to 25K as well. She seems smother for sure. Next I’m doing the ATC_ANG up to 6 and retesting. (baby steps lol) Then onward to VTOL. Thank you for you input and time, I really appreciate it.


Final flight before the vtol tune. I just again wanted to express my gratitude for your help and insight with this. She is super smooth and I’m no longer worried about stability. :smiley:




You can safely set this now:

The harmonic notch filter is working well, you dont need to adjust that:

Dont be alarmed by those big peaks that dont have a notch on them, their noise is not getting through.

Move on the the VTOL Quick Tune, and maybe even an Autotune after that.

So all has been worked out. Drone is very stable in all flights, and all weights. VTOL QUICK TUNE is absolutely the way to go. Very safe and straight forward. no twitching and jerking like standard Autotune. I have built a lot of drones over the years and have never really like the standard autotune option. But now with this as an option I am happy to say that “this is the way”. Thank you to everyone that helped with this endeavor. Especially @xfacta (Shawn).

Now if there was an easy solution for hot swapping batteries without a reset. Again thanks to all.

Here are the logs from the latest flight at full weight.

That looks very good, I dont see any stand-out issues at all.
Just closely monitor the vibrations over time in case any problems are creeping in - that’s one advantage of good tuning, easier to spot problems.

You could go to ATC_THR_MIX_MAN,0.5 which is normal, and reduce logging a little: LOG_BITMASK,32702
And I would probably remove an unnecessary notch INS_HNTCH_HMNCS,11

After the first couple of notches (harmonics) the main low pass filter (INS_GYRO_FILTER) usually has enough attenuation to take care of all the higher frequencies.