Link pairing impossible

#1

Hello, i received 2 herelink units. The beta 2.

One unit worked flawlessly out of the box.

The second one does not link to the air unit. I reflashed both firmwares (0.2.2) on both using the flash-all.bat

Still impossible to pair.
D2Dinfo shows nothing, and when i go into service mode, it seems that the transmitter works.

I don’t know if there is a problem with the air unit or the remote unit, since i don’t have the second unit with me.

I tried to downgrade to the 0.2.1 firmware on the remote but the file on the site is broken.

Some one could please share it ? Thanks.

#2

looks like no one else has this problem or no one know how to help…
It’s a pity…

#3

@nicodh Please wait for instructions for deriving more info from your hardware, we are looking into the issue.
Meanwhile, please upgrade to the latest version with flash_all.bat and follow the steps mentioned here closely https://docs.cubepilot.org/user-guides/herelink/one-time-setup#pairing-with-air-unit . If possible a short video showing the process you are following will be helpful as well.

#4

thanks Sidbh,
already did the latest and it does not work, that is why i’m asking for the older firmware so i can downgrade test and upgrade again.

#5

Here it’s the result of the flash all…
1%20boot%20bootloader 2%20flash 3%20check%20fastboot%20device 4%20flashing%20all files

Here it’s the result of the flash_all.bat from cmd:
C:\platform-tools\RemoteUnit_FW_0_22>flash_all.bat

C:\platform-tools\RemoteUnit_FW_0_22>fastboot getvar stage 2>&1 | findstr /r /c:“stage: romboot” && fastboot boot C:\platform-tools\RemoteUnit_FW_0_22\images\firstboot.img &&

C:\platform-tools\RemoteUnit_FW_0_22>fastboot getvar product 2>&1 | findstr /r /c:“product: optimus” ||
product: optimus

C:\platform-tools\RemoteUnit_FW_0_22>fastboot flash modemarm C:\platform-tools\RemoteUnit_FW_0_22\images\modemarm.bin ||
Sending ‘modemarm’ (16836 KB) OKAY [ 0.415s]
Writing ‘modemarm’ OKAY [ 0.412s]
Finished. Total time: 0.937s

C:\platform-tools\RemoteUnit_FW_0_22>fastboot flash modemdsp C:\platform-tools\RemoteUnit_FW_0_22\images\modemdsp.bin ||
Sending ‘modemdsp’ (12284 KB) OKAY [ 0.287s]
Writing ‘modemdsp’ OKAY [ 0.303s]
Finished. Total time: 0.674s

C:\platform-tools\RemoteUnit_FW_0_22>fastboot flash boot C:\platform-tools\RemoteUnit_FW_0_22\images\boot.img ||
Sending ‘boot’ (24336 KB) OKAY [ 0.577s]
Writing ‘boot’ OKAY [ 0.585s]
Finished. Total time: 1.299s

C:\platform-tools\RemoteUnit_FW_0_22>fastboot flash system C:\platform-tools\RemoteUnit_FW_0_22\images\system.img ||
Sending sparse ‘system’ 1/23 (56015 KB) OKAY [ 1.376s]
Writing ‘system’ OKAY [ 2.114s]
Sending sparse ‘system’ 2/23 (53878 KB) OKAY [ 1.426s]
Writing ‘system’ OKAY [ 1.571s]
Sending sparse ‘system’ 3/23 (57340 KB) OKAY [ 1.401s]
Writing ‘system’ OKAY [ 1.424s]
Sending sparse ‘system’ 4/23 (56997 KB) OKAY [ 1.433s]
Writing ‘system’ OKAY [ 1.527s]
Sending sparse ‘system’ 5/23 (57343 KB) OKAY [ 1.571s]
Writing ‘system’ OKAY [ 2.066s]
Sending sparse ‘system’ 6/23 (56906 KB) OKAY [ 1.482s]
Writing ‘system’ OKAY [ 1.574s]
Sending sparse ‘system’ 7/23 (57343 KB) OKAY [ 1.537s]
Writing ‘system’ OKAY [ 1.760s]
Sending sparse ‘system’ 8/23 (56837 KB) OKAY [ 1.440s]
Writing ‘system’ OKAY [ 1.489s]
Sending sparse ‘system’ 9/23 (54214 KB) OKAY [ 1.431s]
Writing ‘system’ OKAY [ 1.597s]
Sending sparse ‘system’ 10/23 (57252 KB) OKAY [ 1.351s]
Writing ‘system’ OKAY [ 1.412s]
Sending sparse ‘system’ 11/23 (54550 KB) OKAY [ 1.378s]
Writing ‘system’ OKAY [ 1.971s]
Sending sparse ‘system’ 12/23 (57222 KB) OKAY [ 1.552s]
Writing ‘system’ OKAY [ 2.622s]
Sending sparse ‘system’ 13/23 (54898 KB) OKAY [ 1.361s]
Writing ‘system’ OKAY [ 1.628s]
Sending sparse ‘system’ 14/23 (57253 KB) OKAY [ 1.499s]
Writing ‘system’ OKAY [ 2.223s]
Sending sparse ‘system’ 15/23 (54163 KB) OKAY [ 1.412s]
Writing ‘system’ OKAY [ 1.612s]
Sending sparse ‘system’ 16/23 (57341 KB) OKAY [ 1.375s]
Writing ‘system’ OKAY [ 1.572s]
Sending sparse ‘system’ 17/23 (57332 KB) OKAY [ 1.442s]
Writing ‘system’ OKAY [ 1.441s]
Sending sparse ‘system’ 18/23 (56442 KB) OKAY [ 1.472s]
Writing ‘system’ OKAY [ 4.801s]
Sending sparse ‘system’ 19/23 (56050 KB) OKAY [ 1.443s]
Writing ‘system’ OKAY [ 1.614s]
Sending sparse ‘system’ 20/23 (56737 KB) OKAY [ 1.515s]
Writing ‘system’ OKAY [ 1.925s]
Sending sparse ‘system’ 21/23 (57236 KB) OKAY [ 1.573s]
Writing ‘system’ OKAY [ 2.563s]
Sending sparse ‘system’ 22/23 (57342 KB) OKAY [ 1.419s]
Writing ‘system’ OKAY [ 2.029s]
Sending sparse ‘system’ 23/23 (6004 KB) OKAY [ 0.144s]
Writing ‘system’ OKAY [ 2.550s]
Finished. Total time: 83.516s

C:\platform-tools\RemoteUnit_FW_0_22>fastboot flash userdata C:\platform-tools\RemoteUnit_FW_0_22\images\userdata.img ||
Sending ‘userdata’ (23569 KB) OKAY [ 0.551s]
Writing ‘userdata’ OKAY [ 0.618s]
Finished. Total time: 1.270s

C:\platform-tools\RemoteUnit_FW_0_22>fastboot flash recovery C:\platform-tools\RemoteUnit_FW_0_22\images\recovery.img ||
Sending ‘recovery’ (28328 KB) OKAY [ 0.699s]
Writing ‘recovery’ OKAY [ 0.681s]
Finished. Total time: 1.532s

C:\platform-tools\RemoteUnit_FW_0_22>fastboot flash cache C:\platform-tools\RemoteUnit_FW_0_22\images\cache.img ||
Sending ‘cache’ (6248 KB) OKAY [ 0.146s]
Writing ‘cache’ OKAY [ 0.170s]
Finished. Total time: 0.379s

C:\platform-tools\RemoteUnit_FW_0_22>fastboot flash misc C:\platform-tools\RemoteUnit_FW_0_22\images\misc.img ||
Sending ‘misc’ (8 KB) OKAY [ 0.003s]
Writing ‘misc’ OKAY [ 0.009s]
Finished. Total time: 0.042s

C:\platform-tools\RemoteUnit_FW_0_22>fastboot flash firstboot C:\platform-tools\RemoteUnit_FW_0_22\images\firstboot.img ||
Sending ‘firstboot’ (292 KB) OKAY [ 0.010s]
Writing ‘firstboot’ OKAY [ 0.018s]
Finished. Total time: 0.061s

C:\platform-tools\RemoteUnit_FW_0_22>fastboot flash trustzone C:\platform-tools\RemoteUnit_FW_0_22\images\trustzone.img ||
Sending ‘trustzone’ (428 KB) OKAY [ 0.013s]
Writing ‘trustzone’ OKAY [ 0.020s]
Finished. Total time: 0.067s

C:\platform-tools\RemoteUnit_FW_0_22>fastboot flash secondboot C:\platform-tools\RemoteUnit_FW_0_22\images\secondboot.img ||
Sending ‘secondboot’ (2812 KB) OKAY [ 0.068s]
Writing ‘secondboot’ OKAY [ 0.084s]
Finished. Total time: 0.195s

C:\platform-tools\RemoteUnit_FW_0_22>fastboot reboot ||
Rebooting OKAY [ 0.004s]
Finished. Total time: 0.014s

After that the tablet boots and qgroundcontrol shows the warning please pari first. So i click yes and do the reset/pair 3 second button…

fail to pair…

Going in hardware tests, and then clicking in D2Dinfo, i can see of course that it is disconnected.

I tried to find a way to look into the receiver side how to check if the radio is on, but couldn’t (i went into adb shell).
I can see the ip configuration and i see that it’s not getting to connect…

Please tell me if there is another way… And i still would like to test to downgrade and then re upgrade (maybe i will connect on the 0.2.1 version firmware)

thanks

IMG_0454%5B1%5D

#6

had the same issue when i wasn’t supplying the air unit with enough power.

1 Like
#7

Really you need to try swapping them around if you can, as you have paired one You know the process. As mentioned check the voltage your supplying it.

Other than that I’d speak with your retailer and return.

#8

For power i’m using a 3S battery directly to the air unit, so i don’t think it’s a power issue.

The other unit is not at the same place as this one, and it’s already in a UAV for testing purposes.

The retailer is not answering back from me.

#9

Who was the retailer