List of Problems of HERELINK Apps

Hello all, we have been using HERELINK for almost two years and a half in the company, and I would like to share a list of the things that I have seen not to work, to see if there is any way that they could be fixed.

Note: My Herelink Units are updated to the last version and so is the SOLEX app

QGroundcontrol APP: Finally this app got to work pretty decently but it has a big problem: It cannot save the video stream. When you push the record button the video feed freezes, and gives as a result corrupted files. In previous versions of Herelink Firmware, it was working sometimes, with problems and freezing sometimes. After the last update, it does not work at all.


Since it was required for us to record the video stream and we could not do it with Qgroundcontrol, we had to move to SOLEX. After testing SOLEX for some time I have realized that the video recording feature works really well, but there are many things that does not work:

  • There is a checkbox in the app settings that says save files to SD card. Even if it is checked, I cannot get the videos to be stored straight on the SD card.

  • There is not any reading of the battery voltage on the main screen. There is one in the HUD view, but it has not decimals. I think it would be great to have 1 or even 2 decimals since a big portion of the battery time goes from 22 to 21 V.

  • The app crashes many times, when you select some options.

  • I could not record any video when the HUD is active. It would be very cool to still enable the video record when in the HUD view.

  • When you go into the mission planning or map tab, there is an option to go to a location using the name of the city, zipcode and so on, it does not work even if you are connected to WiFi.

  • On the layer menu, under logs you can choose Save Location, then a small triangle appears on the map, however I do not know how to retrieve the coordinates of that point, it just adds the triangle on the map.

  • Under app settings there is a checkbox for a kills switch that should appear on the screen, but it is not there.

  • Guided mode does not work, you can select that mode and touch the screen bun nothing happens.

  • There is an icon under the controls menu, bellow the checklist and above the leds control, that looks like a circle inside a target. When enabled, ad circle with a small square inside appears on the screen but I have no clue what this is for. Nor appears on the manual.

  • I went to the SOLEX site and downloaded the manual, however many of the things that appear on the manual do not appear in the app. Looks like the manual was made for a way earlier version, so is not really helping much.

Solex looks to me like a way more simple and user friendly app. I think if the previous points were somehow solved it would be a solid app.

As I was reading Herelink is not anymore a Beta product, I do not know if the apps still are, or if the porpuse of Herelink is just provide a platform for the companies to develop their own apps and install them on Herelink.

Thank you in advance.

@Michael_Oborne @kellyschrock @sidbh
For awareness


Hi Abel,

I’m the author of Solex and I’ll answer your items below.

Where are you looking for the files on the SD card? If memory serves, they’re in media directories there.

Long-press on the status bar on the flight screen and a new view will appear below it, where voltage is displayed.

“Crashes many times” does not really tell me anything other than that it crashed for you. What were you doing when it crashed?

Video recording doesn’t happen from the hud. You can start video recording and then switch to the HUD view though.

I’ll check on the address search function, potentially removing it for HereLink. Address search initially required the use of Google Play services, which the HereLink does not have. I switched to using a different service for the Herelink, but it may not be working. It’s dead-certain to not work if you don’t have an internet connection, so hopefully you weren’t trying to search addresses without that. :slight_smile:

“Save Location” saves the current point in the current flight log, accessible from the Flight Log layer.

Guided mode does work, but is simply a vehicle mode. There is no direct connection between Guided mode on the vehicle and tapping on the screen to send the vehicle somewhere. There is a “Guided” layer on the map view, where you can turn that on and long-press on the map to drop a guided point. In that case a vehicle in Guided mode will fly to the point you specified.

The features for Solex from Google Play and Solex on the Herelink are different, owing to the fact that Solex on Google Play works with the 3DR Solo directly and the HereLink version doesn’t. The manual attempts to cover both, evidently not totally effectively. It exists though, which seems like a reasonable start.



Delete please

delete please

Hello Kelly,

Thank you for your answer. I replied to you like 3 or 4 weeks ago (or I thought I did) but looks like my reply did not post, when I opened this thread again today to follow up, I could see my reply on the editor and I deleted it in order to type a new follow up message :man_facepalming: so now I will have to type it again.

Yes they appear in the media directory, that folder is in the internal storage called OPTIMUS. There is a flagbox in the solex app options menu that says store files in the SD card, so I expected a folder to be created and the video files stored in the SD card. What I am doing for now is to copy and paste them form one to the other manually.

Right! I found it really useful.

I was checking and unchecking some flag boxes on the app options menu, I do not remember exactly which ones but I will try again soon and tell you with more detail.

Yes, but as far as I remember, by doing that, when I switch to HUD causes the video to stop recording, I will try it again and see.

I was connected to a 5G WiFi network with internet connection when I tried. This option would be really useful for us in order to preload maps of the areas where you are going to fly and wont have internet connection.

I saw the flags on the map, but is there any easy way to for example, retrieve the lat and long of that point in order to tell a recue team using a Walkie-Talkie where someone was found?

I will try again this weeks and let you know.

OK now this makes sense, I was not aware of that and caused me a little of confusion.

There are a couple of points that you did not answer:

Sorry for the delay, I am still learning how this forum works. I really appreciate your help. I hope you find me feedback useful too.

Thank you again.

Hi Abel,

Sorry for the late response, I started a new job and have been quite busy. Did you get all of your questions answered?