Loss of all satellites on HERE 2 GNSS in-flight

My here2 isn’t updated. But I’m running AC3.6.10.
I’m tried fresh cable and got this issue once. I’m trying to find out which part is actually the culprit whether it’s here2, cable or carrier board. Updating to lastest arducopter version is the only change I have made. Hope firmware isn’t the issue.
@philip I’m also wondering why GPS failsafe trigger before it started flying away at high speed till it gets back location.

First… if you have not updated the Here2… do it now.

Hey @philip
@tiffo has got the issue even after updating. What are the improvements over current firmware version except for the CAN support? Because I have updated only one here2 GPS for testing and rest are in stock firmware.
@tiffo how many times have you experienced this?

I’m 99% sure this is not a Here2 issue. We need to get a predictable failure, so we can find the exact cause. Our team are looking at hardware, and the ardupilot team are looking at their end.

The uBlox will not “reconfigure” or be “re-found” without a command being sent from somewhere

Yes. Here GNSS has been the most reliable since i started using them. I’m also wondering whether its the Ublox module which might be behaving like this. I mean, some batches of them?
We tried swapping cables, and reconfig message popped up once.
After swapping it to new autopilot, I’m not getting reconfig messages.
We switch back to old setup with old cable and have been testing from past 2 days and haven’t got the reconfig message.
For testing purpose whether its power issue,
We also tried removing power to Here2 for a fraction of second manually, Ublox reconfig happens with “compass not healthy” message. which means the power is gone both from GPS and compass.
Sorry for huge post. Just trying to narrow things down.
Thank you

It is common for my survey grade GPS to lose connection with the controller. Usually I cause it with a bump. Once a day possibly but it is not repeatable, it just happens even with gold standard stuff.
I realize you would like to pinpoint a component and I hope you can. Obviously it’s not easy to do.
However we are using GPS beyond recommendations by using it for our main navigational source. I wonder if the flyaway could have been prevented. How can it be prevented when a GPS glitches other than adding a 2nd GPS?

@Mallikarjun_SE it happened only once in five days, but of course during a demo

At the end of the day, we have the capability, and recommend dual GPS. It is the ONLY way to deal with gps glitches that we all know to happen. Please use CAN as your primary GPS.

1 Like

Hey @philip
Dual GPS on small aircrafts is really hard to manage. I’m also wondering why arducopter code didn’t consider it as GPS glitch when all satellites were gone. There was a flyaway situation instead. Probably there was not enough ekf error build-up. Our tests indicated that there was no power issue. Really hoping to narrow down the problem.
Thank you!

the second GPS can be anything you want… best if its good quality like the Here2, but a mini gps would be better than none

@philip, Whats he recommended ardupilot setup for 2 gps’s, Just get them both working and set GPS_AUTO_SWITCH=1?

Hey @philip
Yes. I just added a small GPS as backup. I’ll be using switch to best option.
@Josh_Tepper I’d be using GPS_AUTO_SWITCH=2, i.e, Blend if I have 2 here gnss. It really works good. I’d go with 1 if second GPS is mediocre.

1 Like

I think the issue with Blend, is it will happily blend bad data with good data, and produce a bad position estimate. So you haven’t really added any protection, its now just if any GPS fails, you will have an issue.

2 Likes

Use option 1. It’s uses best available GPS.

From the ArduCopter documentation, “Normally blending should be done with two GPSs from the same manufacturer because the scaling of the accuracy numbers varies and will lead to favouring one GPS over the other.” (http://ardupilot.org/copter/docs/common-gps-blending.html#gps-blending-aka-dual-gps)

1 Like

[EDITED] I plugged one here2 as i2c and the other as CAN. Setting GPS_TYPE = 1 and GPS_TYPE2 = 9 got both the GPS running. I cannot detect the compass on the CAN bus though

Can is last to detect, so if you want it to show up, you need to use the compass mask to only detect the exact types of compass that you want.
So ignore lsm303d and mpu9250

Hello,
@Mallikarjun_SE, I noticed the same issue on several hardware (Here2 & Cube). Each time a loss of all satellites during 11,3 seconds. This post is quite old but could you finally identify the root cause of this reboot? I checked Here2 firmwares, everything looks up to date. I suspected initially a problem with the power supply but the problem remains even after putting the Here2 on a dedicated and stable 5V supply.
Thanks!

Hey! I couldn’t find a reason for this issue. I haven’t experienced it after moving to CAN. Are you on CAN or Serial? Share logs.

We are using Serial. I am sorry, I don’t have any log that I can share right now, I’ll see if I can manage to send one. Anyway, we periodically have this issue so I’ll try switching to CAN and see if it solves the issue. Thank you for your help!

1 Like