Mav link down when connected to telem with battery

I connected my Orange Cube Here 3 to my raspberry pi using USB, which works well. But I tried to use UART.

Connecting the Raspberry pi to Telem 2. Connecting both TX, RX and Ground. Even the 5V+. When I power the external power on my raspberry it works. (Raspberry now is powering the Cube)

Now I remove the external power to my raspberry. Connect my raspberry to the same battery source that power the cube.

When I turn on it sound exactly the same with the buzz. But when I tried to connect to the flight controller using Mavproxy. it shows Link 1 Down. Anyone knows why?

Can you try to remove 5V+ connection between Cube and pi?

Also, can you show the circuit diagram/picture?

The diagram is how I connect it.

You need some extra setup before communicating via serial

Yes I did try but it doesn’t work. I assume it as something to do with supplying power to the raspberry might interfere with the signal on the UART Pin on the raspberry.

Currently the Raspberry power I connected 5V Ground to GIO pin as well on Pin 2 (5V Power) and Pin 6 (Gnd).

Telem 2 Gnd to pin 6, Tx to Pin 10(RX), Rx to Pin 8 (Tx)

Maybe I would try supplying power using a Micro USB plug instead of the GIO pin to see if it works.

I tried using battery to micro USB to power the raspberry, it doesn’t work as well.

The only way that it will work is when I connect the raspberry to a separate power source from the Orange cube. Or if its the same power source, then only USB works but not serial. I really don’t know why.

You can’t power the raspberry pi by its gpio