Motors not turning at the same rate


  1. After complete installation and calibration ( Quad X ) i observed that the PWM value from 2 pins aren’t correct.
  2. Ardupilot - After Arming with 2 motors on the left ( motor no. 3 & 2 ) were slow and the aircraft was rolling left.
  3. PX4 - After arming 2 motors on right ( Motor no. 1 & 4 ) were slow and the aircraft was rolling right, after doing everything again ( re calibration and setup ) motor 3 & 4 were slow.
  4. I did calibrations again on a different aircraft and observed the same behavior.

I have tried with PX4 & Ardu both to ensure if the issue is because of calibration. Haven’t faced an issue with any of those.

Have attached the logs.

Thanks in advance :slightly_smiling_face:

log_23_2021-11-26-12-50-18.bin (1.5 MB) log_23_2021-11-30-14-13-00.ulg (2.4 MB)

RCOU.C2 and C3 seems not matching well with C1 and C4 in the first part. Their output signals were slightly lower.

The desired attitude and achieved attitude in roll and pitch are not matching good. I assume this is because the copter was not tuned.

I think the autopilot knows and controlled those 2 motors to spin slower. You may try to tune it briefly and see if it would improve. Also check your cg of the copter so that thrust from each motor are balanced.

You may also try to assign motors to different PWMOUT channel to verify if specific channels cause the problem.
This can be done by modifying SERVOX_FUNCTION

1 Like


Many thanks for your response. I appreciate your effort.
We did the calibration again yesterday incl. esc calibration.
C.G is properly balanced too.
Motor 2 & Motor 3 spin at a higher rate, 1 is comparatively slow, 4 is significantly slow.
To check we interchanged the Motor 3 & Motor 4 wires then motors then Motor no. 3 was spinning slow.

Have you calibrated the ESCs?

Also, can you try the motor test in Mission Planner to verify if all motors are able to spin at same speed when same signal is given?


Yes i have calibrated the ESC’s properly.

Motor test in mission planner works fine throttle percentage 10% and 2,3, 5 secs run works absolutely fine tried with 15%-20-30% thr also. All spin at the same rate.

I did all the calibration again incl. esc calibration & did a test no luck. :confused:

2021-12-06 13-27-43.bin (785.2 KB) 2021-12-06 13-29-51.bin (1.4 MB)

When you say “test” what do you mean? Because the MissionPlanner motor test is the only definitive test.
If the motor test works OK then that’s all you need to verify.
If you are arming with the multirotor tied down or otherwise unflyable, that is not a valid test and the motors will not work as you expect until it is actually flying.

The only other calibration you can do is calibrate level as follows:

  1. do not assume your floor or table is level, use a spirit level to check across the tops of the motors
  2. pack under the landing gear to level the “prop disc” (don’t try to level the actual flight controller itself)
  3. in MissionPlanner, Setup, Mandatory…, Accel, press the Calibrate Level button

You have all default parameters.
Update MissionPlanner to latest beta, in MissionPlanner, Setup, Mandatory… you’ll find Initial Parameters
Put in your prop size and battery cells, accept everything it offers and all the other optional parameters on that page EXCEPT the T-Motor ESC settings (unless you have those ESCs)

Hi @xfacta

I did motor test all 4 motors were spinning properly. Yes motor test was okay.
Copter was armed without and there was nothing attached to it to not let it take off.
As soon as THR is above 20% copter tries to lift ( pitching back ) because 2 motors are spinning slow. if i increase the THR it simply flips.

Did the balancing properly by keeping it on glass slab and checked the level using of that glass surface using spirit level. Calibrate Level done but that didn’t change anything.

I’ll try the latest beta and make changes in the initial parameters to see if that works. Have done a lot of tinkering around for this.

Have been using cube from a while now, never faced anything like this. This new cube orange which i have got recently has surprised me :roll_eyes:

Then it is likely the motor and prop directions are wrong
Be aware the MissionPlanner motor test letters are not the same as the arducopter (and PX4) motor numbers. MissionPlanner motor test always goes from front-right around a clockwise direction.

For example if you test Motor B, then actual motor 4 should spin - and pay close attention to the direction of spin.

1 Like

@Alvin & @xfacta

Many thanks for your response friends.
I have managed to resolve the issue now.

The Carbon fiber sheet on which the FC was mounted was slight bent, its a thin sheet, after multiple calibrations also horizon wasn’t leveled.
I did a complete reset and then leveled everything using spirit level. Made some changes in the PID.
Did calibrations again and it finally worked.
Cue is very sensitive and accurate too i think that’s the only reason that slight curve on the sheet was spiking up the motors to compensate.

Only thing that isn’t good now is the compass calibration. I’m using QGC to do that after calibration the bar shows YELLOW for Internal compass & Extreme RED for the external compass.

Are you using external mounted compass? If so, you may try to disable the internal compass inside the autopilot.

@Alvin Hi

Yes i’m using both internal and external.

Alright I’ll try that.

Thanks buddy!