MP problem after Service bulletin perform

(Peter Legacy) #1

Hi,

I perfomed all instructions in you SB but it resulter that mission planner stuck at stat_runtime and not proceedenig forward and whole system freeze up.

EKF3 - Enabled (This was just a try not affect the problems)
IMU 1,2,3 - enabled
EK2_IMU_MASK - 7 (This is the parameter which brakes the comunication in Mavlink and MP)

Im unable to change now anything since I have no access, Also Herelink controller faills to get telemetry data stuck at downloading

Update1.The problem appear exactly after setting EK2_IMU_MASK - 7
Update2. After full system reset no change just simple after activation of EK2_IMU_MASK to 7 it freeze up
Update3. After cancelation of the loading these params and attemp to put back the EK2_IMU_MASK - to 3 it says set “EK2_IMU_MASK failed”
One more update… it not passing time to time as well FOLL_ENABLE just simple stuck

I tryed to reflash the firmware no change, tryed 3 diffrenet computers, 2 diffrenet ways of telemetry (herelink, 868MHZ RXTX telemetry) also USB on vary bauds no change

    1. 2019 14:22:36 : PreArm: Hardware safety switch
    1. 2019 14:22:11 : Frame: QUAD
    1. 2019 14:22:11 : CubeBlack 004B0042 33385114 38323833
    1. 2019 14:22:11 : ChibiOS: ab2f8d8d
    1. 2019 14:22:11 : ArduCopter V3.6.11 (f0d59294)
(Ian ) #3

Try flashing it to rover then back to copter then try again.

(Peter Legacy) #4

Thanks for idea but dont worked unfortunately… after applying the SB 2 again stucked on the same place… On the moment when EK2_IMU_MASK is changed to 7 if its 3 it works OK In attachement is the configuration file to my setup.

Tarot 650 XR50A.zip (4.5 KB)

(Peter Legacy) #5

I tryed AC 4,0 RC2 and same situation + new fault

    1. 2019 21:04:45 : PreArm: Internal errors (0x8000)

Sometime I feel that the chineese clone for 30bugs is much better never had problems. Since Im using Cube only problems… Maybe just Im not lucky and got faulty piece

Continued…
I went back to 3.6.11 reseted all parameters and only applied the SB instruction. Without success for now giving up. Probably I return the unit to reseller bcs without Implementation of SB I will not use the Cube… Noway with thermal imager for thousands of dolars.
I tryed complete parameter

(Cornel Fudulu) #6

Why ?

(Peter Legacy) #7

This was only a try… No reason for it I just tryed… but Now im sure there is no problem with my params bcs I fully reseted ALL paramaters and after setting EK2_IMU_MASK to 7 it stucks. I tryed several versions of MP as well several type of comunications so now the drone is grounded until this is not clarified and anyway the herelink controller is not working bcs it stucks as well

UPDATE: Now after more than 10 resets and FW changes and etc… It started to work and not causing at this moment the problem with MP and MAVLINK… without any known solution why it started to work. So until Philip or somebody who is expeirenced with this issue dont say it will not affect the safety that it started to work without to know what caused the problem I will keep the drone on ground and consider as not safe.

(Ian ) #8

If your now connecting I would flash to Rover or plane then back to Copter and entirely setup from scratch again.

#9

Start from scratch please like Ian said.

(Peter Legacy) #10

Phillip Thanks, its done several times… but result is probably unsafe bcs during flight the EKFs are changing so many times and getting IMU problems. Everything worked well before I applyed this SB the copter was OK. Im working on… How its with beta 4.0 Is it safe to use?

(Cornel Fudulu) #11

Unless you’re trying DShot or BlHeli32 ESC telemetry, master is performing well. No glitches in 20+ flights so far. The dynamic harmonic notch filter does wonders.